As dead as a door(bell)? - New Ring Pro

Hello, we recently installed a Ring Pro. It came online, worked fine for about a day, events and timeliness captured fine, voltage showed fine in app. It now shows disconnected.
We tried a reset, full reset, unplugging for a few hours - nothing works. We bought a new power adapter - still nothing.
It originally had a dim white light, now it has nothing. We can hold the reset button down for 30 seconds and it will go to a rotating white light then back to nothing.
We have verified voltage at unit and all seems to be fine.
None of the knowledge articles seem to cover this, but we have tried all suggestions except plugging in a microUSB to left side plug. Not sure if this voids warranty?

Any ideas?
Thanks!

Hey @Jchawk. Please read our Help Center Article here for more information on how to troubleshoot this. If you still have a concern, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.