App version 5.44.0

In the latest application build, ver 5.44.0, when viewing videos in the timeline view on an iPad, horizontal, which is how I’ve always used the application, videos are zoomed in, cutting off the top and bottom portion. Squeezing the picture does not correct this. iPad iOS 15.0.1. Also found that I can’t get rid of the discover panel on the dashboard screen.

Mike55 -

When you say “iPad IOS 15.0.1" are you referring to:

  • iPadOS 15.0.1 and/or
  • IOS 15.0.1

On a device running both iPadOS 15.0.1 and Ring app 5.44.0… I tried to duplicate the timeline view problem you described, but was unable to do so.

When the Ring timeline feature is displayed on the screen, have you tried:

  • Using one finger to “double-click” the video clip itself? (In other words, tapping the video clip with one finger twice in a row?)

This method acts like a toggle, moving back and forth between displaying video clips in a normal view versus a zoomed-in view. In your case:

  • If a video clip is “zoomed in”, tapping it twice in a row with one finger should cause it to revert to a normal view.
  • If you double-click a video clip with one finger again, a “zoomed in” view should be displayed.
  • Please post here to indicate if this solves your “zoom” problem.

Regarding the “Discover” image section on the Dashboard, you are correct. Ring needs to remove the Discover image section and the “Set Up a Device” link below it. Neither belong on the Dashboard. (If you agree, you may want to search for the word “Discover” on the Feature Request Board on this website and “vote” for any threads you agree with.) It would presumably take very little effort for Ring to fix these problems, so it’s very disappointing they have not done so.

When you say “iPad IOS 15.0.1" are you referring to:
Answer, I am referring to the iPad operating system.

Tapping the zoomed in video with a single tap only causes the video to pause, no affect on the zoom.

More than ever now, always hesitant to update the Ring Application. Most always more things are broken than improved.

Mike55 -

I’m sorry to hear that you are still having issues with the Ring app iPadOS 5.44.0 version Timeline screen.

It sounds like the “SINGLE tap with one finger” feature is working for you. In other words, on the Timeline screen, each time you SINGLE tap the video clip that is currently displayed on the screen with a one finger, it switches to the OPPOSITE Play/Pause mode.

  • If the video clip is currently in Play mode, a single tap with one finger pauses the video clip.
  • If the video clip is in Pause mode, a single tap with one finger plays the video clip.

What happens when you use the “DOUBLE tap with one finger” feature? In other words, when the Timeline is on the screen, each time you tap the video clip on the screen TWICE in a row with a single finger, the Zoom mode should switch to the opposite Zoomed-In/Normal mode.

  • If the video clip is currently displayed in a zoomed-in view, a DOUBLE tap with one finger should change the view to “normal".
  • If the video clip is currently displayed in a normal view, a DOUBLE tap with one finger should change the view to “zoomed in”.

With the Ring app iPadOS 5.44.0 version, you may find that video clips from different types of Ring cameras look quite different on an iPad device in Landscape mode (perhaps, due to the different camera lenses in the Ring devices).

For example:

  • A Ring Floodlight Cam (1st Gen) video clip:
    • May look pretty much the same as it did in the previous version of the iPadOS Ring app.
  • A Ring Doorbell Pro 2 (2nd Gen), however:
    • Will take up much of the screen vertically
    • Will have vertical Grey borders on the left and right side of the screen
    • Will have a horizontal, “translucent” Black strip that is (somewhat) near the bottom of the video clip. Because the horizontal Black strip is translucent (instead of solid), the portions of the video clip that fall above and below the translucent strip will be shown with normal/expected lighting. The portion of the video clip that is “behind” the horizontal translucent strip, however, will be dimmer and more difficult to see.

Another thing that may be different in the Ring app iPadOS 5.44.0 version is that you may no longer be able to use your finger to move the video clip around on the screen to (temporarily) view a portion of the video clip that is not currently displayed on the screen. Is this what you are referring to as “zoomed in”? (If so, it is a TOTALLY DIFFERENT concept than the “normal/zoomed-in” TWO tap with one finger method described above.)

Does any of the information in this post help you at all?

Double tap does not change the picture size. All cameras, various types and generations are affected in exactly the same way. Top/bottom portions are cut off, picture is grainy due to the zoom. I’ve checked tap adjustments in settings to fine nothing that would correct this.
When using the iPad in vertical mode as a smartphone would normally be positioned, all is “normal”.

Double tap works as it should in horizontal position when viewing a video in full screen and live. It does nothing in time line view. Time line is where the problem manifests itself.

Mike55 -

You certainly seem to be experiencing some unusual symptoms.

I am UNABLE to duplicate the symptoms you are experiencing, but can confirm that there appears to be a noticeable difference in the way the Ring Timeline screen is displayed, depending on the version of iPadOS.

For example, consider the following two scenarios:

  • Device #1: iPadOS 4.8 (and Ring iPadOS 5.44.0)
  • Device #2: iPadOS 15.0.1 (and Ring iPadOS 5.44.0)

With Device #1, if you display the Ring Timeline screen while the device is in Landscape mode, then PHYSICALLY turn the device to a Portrait orientation (i.e., vertical, like a cellphone), the Ring app does NOT recognize the orientation change. Because of this, the Timeline screen is rotated 90 degrees in a counter-clockwise direction, making it difficult to view.

With Device #2, if you display the Ring Timeline screen while the device is in Landscape mode, then PHYSICALLY turn the device to a Portrait orientation, the Ring app recognizes the orientation change and switches the Timeline screen to be displayed in Portrait mode.

Thank you for your input. I also use the Ring app on an iPhone 10 with iOS 15.0.1 and do not experience the problems that I do with the iPad. My workaround is to turn the iPad in portrait orientation, and am trying to get use to that. Normally I’ve locked the iPad in landscape, so a bit of a pain.
I can’t remember the sequence of when I updated the iOS and when the Ring App was updated to 5.44.0, (which came first) as both updates were close to each other; so not sure which update or a combination of both is causing this for me. iPad is an 11 pro.

Mike55 -

It’s unfortunate that you are unable to use the Ring app in Landscape mode on your iPad Pro 11" – particularly, if you normally have a physical keyboard attached.

Since no one else has posted on this thread, it’s unclear if you are experiencing bizarre, outlier problems or if other iPad Pro 11" users are experiencing the same issues.

It would be nice if other Ring Community members weigh in on the subject so that users who have an iPad Pro 11" know if it’s safe to install iPadOS and/or Ring app updates.

Yes, thank you for your time and input, we’ll see if anyone else adds to this thread.

Mike55 -

Clearly, I spoke too soon.

As I mentioned earlier, previously, I was unable to duplicate the symptoms you were experiencing on your iPad Pro 11".

Unfortunately, I am seeing some of them now. (Apparently, Ring must be able to control when a user “sees” changes that were included in an update – since I didn’t perform any operating system updates and/or Ring app updates in the interim.)

Unfortunately, I don’t have time to play with the Ring app right now, but it’s obvious that a number of changes have occurred in the iPADOS version of the Ring app – some of which are very undesirable.

It’s difficult to tell if some of the problems are due to poor design decisions and/or programming bugs. It’s almost as if I have an Alpha or Beta version of the Ring app, rather than a Production version.

Your findings are quite interesting. Staged rollout of firmware is normal, certain features of software too. This suggests that development might not pay as much attention to iPad behavior as most are probably using smartphones. As I mentioned earlier, I find no negative impact of ver 5.44.0 using an iPhone.

When I installed 5.44.0 and noticed the problems, I contacted Ring support for assistance. The technician stated that they would report the issue to development, if that actually ever goes that far.

So that I understand, you have not performed an OS update since installing 5.44.0? Again, interesting findings. Now more than ever, I’m hesitant to install Ring updates, as historically things are broken, some more frustrating than others. I see why you are Frustrated427.

Public beta testing…… I was part of the Ring Explorer program and always wondered if they invited me to participate because I’ve had so many problems with their products over the years; I must say though, their products and features are far superior compared to others.

Mike55 -

Like you, I am reluctant to install Ring updates – for a variety of reasons.

Unfortunately, I don’t have time to play with the Ring app right now, but I can provide you with a few quick observations:

  • The iPadOS version 5.44.0 of the Ring app is DEFINITELY in need of Beta testing.
  • In some cases, it’s difficult to tell if specific problems are due to poor/inconsistent design decisions and/or programming bugs.
  • It’s possible that some of the current problems were present in the previous version of the Ring app.
  • For some reason, there are basic inconsistencies in how a particular video clip appears on the screen, based on which Ring feature is being used and/or whether the iPadOS device is in Landscape or Portrait mode.
  • Physically rotating an iPadOS device can present the user with different/unexpected/bizarre experiences.
  • In some cases, user actions on one screen negatively impact the user experience on one (or more) other screens.
  • Some actions are only available if a video clip is in “Play” rather than “Pause” mode.
  • There are a number of obvious differences in the Ring app, depending on whether a device is running iPadOS 15.0.1 (versus iPadOS 14.8):
    • Some of the differences may be due to enhanced capability that is available to software developers in the newer version of the operating system.
    • Other differences may be due to poor design decisions and/or programming bugs
    • Still others may be due to actions previously taken by the user in one (or more) other Ring app screens

If you have quite a bit of experience in beta testing, you may have noticed a lot more anomalies than the ones mentioned above.

I’m still on iPad OS 14.7.1 and I have the exact same issue as Mike55 with the latest update.

1 Like

Questionmark -

Thanks for posting your observation.

Ring Moderators -

Could someone submit an error report for the Landscape mode zoom-related problems in the iPadOS 5.44.0 version of the Ring app for the following features?

  • Event History Timeline
  • Full Screen

For some reason, in Landscape mode, video clips are not displayed at a zoom level of 100%. Worse yet, there seems to be no easy way to solve the problem while keeping the device in Landscape mode. (Using the iPadOS “pinch closed to zoom out” gesture does not work.)

1 Like

Hi neighbors. Thanks for letting us know about this concern. I’ve shared this post with the appropriate team for further investigation. If they find anything, we’ll be sure to update you.

1 Like

Tom_Ring -

Thanks for reporting the bug.

Fortunately, it’s very easy to reproduce. Unfortunately, it’s a very annoying bug that is negatively impacting two (important) Ring features.

Hopefully, the team members you mentioned will instantly recognize the problem if they attempt to use the Ring Event History Timeline and Full Screen features on a device running iPadOS in Landscape mode. If not, please post here and I can provide some specific hints. (I assume other posters can, as well.)

1 Like

I installed the latest application version that was just released today, 5.45.0. This problem has not been fixed.

Mike55 -

Did you notice that Ring programmers did NOT take time to include important bug fixes for two features, but did take time to update the adverting in the app (as well as adding a Red dot on the menu icon and a Red number badge in front of the Shop Now menu)?

Obviously, including marketing/advertising in the app is both unnecessary and inappropriate.

Thus, this is simply the latest example of the skewed priorities assigned by Ring management.

1 Like