App says "Please enter a valid phone number"

Hi @hariat. Is the Ring Alarm system you are using being setup in the UK? If possible, can you upload a screenshot of the error you are receiving so I can look into this for you.

Was experiencing this issue and looks like it’s still an ongoing issue with the app.

SOLUTION:

  1. Disconnect from Wi-Fi and use cellular data when it’s asking to enter phone number.
    (Vice-versa) if on cellular data.

The two-factor screen can also be bypassed if you go to Devices and then Dashboard.

Overall app is okay but not without its security flaws.

I am having the same issue we’re you able to get a fix?

Looking for some help with the same issue

Still a mess…. What a joke. Entered my phone number and it came up invalid.

Micky mouse issue, sort it out these devices are so overpriced for what they are it’s ridiculous. At least get on top of this issue it’s so frustrating.

We had the same problem. Based on tech support’s recommendation, we logged out of the app and logged back in. Problem solved, it took the number.

2 Likes

I can’t believe I can’t enter my phone number. This gives me no confidence in Ring, I’m tempted to return everything. Even basic apps have no problem letting you enter your number, I’ve never had this issue before.
Ring, get your act together. This is a known issue and it’s still ongoing. None of the posted ‘solutions’ have done a thing to fix it.
You guys are a billion dollar company, why can’t you get basic features to work? There is no excuse for this.

I just had my doorbell delivered today and experienced exactly the same problems. What I did which worked first time is:

  1. Back up out of the phone number registration.
  2. Download the Google Authentication App, there are other such apps. Use this to generate an authentication code which you can then paste into Ring app instead of relying on the mobile number to receive text for 2f authentication.
  3. Click on top left of Ring app to access menus. Go to ‘account settings’ and in this option you can select ‘add phone number’.
  4. Click ‘save’ and it should be done

Sept 2022 and this simple bug is STILL NOT FIXED. No confidence if you can’t do something as simple as this .
May return it

Sept 19th 2022. Still not fixed. Have tried every solution suggested here.

1 Like

Hi neighbors. If the suggestions in the marked solution do not work and you’re still unable to enter your phone number, please follow up with our support team so they can take a look and explore more in-depth troubleshooting options.

Ring - YOU HAVE A BUG HERE!

I am in the UK and both the browser and the APP will not accept my mobile number for 2 step authorisation.

DO NOT ASK ME ABOUT VPN - I don’t have one!

Please help me and other customers who have spent a fortune on your products SORT your software BUG!!!