App Issues

When I am connected to my wifi and opens my ring app it clicks and tells me I’m not connected to my wifi. When I disconnect from my wifi, close the ring app and reopen, it loads up right away. This includes my alarm status and cameras. Community and everything else in the app is working fine.

This is the ONLY app that it’s doing this for. Everything else is working fine. YouTube, Netflix, chrome , etc all are fine. Wifi is getting 150+ Mb upload and 34mb download.

Hi @SteelersPensR1. There is currently an outage with the Ring app affecting many aspects of the app. You can keep an eye on the status of the outage here to see when it has been resolved. If the outage has been resolved and you are still not able to load the Ring app, try the following steps:

  • Verify that your Ring app and smart phone are caught up with the latest updates available.

  • Disable any active VPNs on your phone or network.

  • Restart your router by unplugging it and plugging it back in.

  • Forget your wifi network from your phone’s settings and reconnect to it.

  • Reset the network settings on your phone if possible.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.