Alexa routine to arm ring alarm no longer working

Recently the Alexa routine that set ring alarm to away mode has stopped working, it just does nothing now. I can arm the alarm by voice still but not via a routine.
I have removed the Alexa skill for Ring and reinstalled etc but stiill the a routine will not set the alarm to away mode.
Any ideas please how to get this working again?

2 Likes

We are also having this problem. Frustrating!

Doesn’t make sense that we can TELL Alexa to arm, but not via a (previously working) routine. :thinking::face_with_raised_eyebrow:

It clearly has to do with the latest Ring app update, as it coincides with when the problem began.

1 Like

I’m ultra frustrated that this isn’t working, I loved my Good Night routine shutting off all my lights and arming the alarm. Now it’s just obnoxious.

Having the same issue here… no warning. Very frustrating.

Omg ! I tought i was alone. Exactly the same issue. ULTRA frustating… I left home 3 times without my alarm in less than a week… You get use to very convenient development and then it’s removed without any notification…

Please someoen correct this !

This thread has also mentioned the same thing

I have the same issue starting this week. It allows me to use the voice command through Alexa but the routine no longer works. I have deleted this skill deleted the Ring device from Alexa. And re-downloaded the skill, enabled it and re-added ring. It just won’t work with the routine. I even created a brand new routine to try that way.

Same here. I hope the fix it quick.

I ran into the same issue on a “good night” routine this week. An estimated fix time would be nice

Hey neighbors. Thanks for bringing this to our attention. I’ve notified our teams here to look into this. We’re sorry to hear Alexa is having difficulty controlling your Ring Alarm; rest assured that our team is investigating and working to resolve the issue as soon as possible. If there’s anything else I can help with in the meantime, please don’t hesitate to ask. For the time being, I’m marking this response as a solution so other neighbors who are experiencing this concern can easily find that we are looking into this. A member of the Community team will update this solution when more information is available.

It worked again last night! Thanks Ring for solving the problem!

1 Like

I’m having the same issue the routine doesn’t arm alarm

This is SO confusing. There are lots of different thoughts in this Community and I’ve spent hours trying to figure this out.

I added the ring skill to my Alexa but there is no option to arm/disarm/away my ring cameras. There’s comments about needing a “Ring Alarm system” with a link to a generic article that doesn’t define what that means.

I have paid for the Ring Protect Plus (1st Gen) but there doesn’t seem to be a way to associate that with my Amazon account.

I also tried setting the custom routine to “arm ring away” or “arm ring away mode” (all of which are mentioned on other sites for how to get this working).

Clearly, the ring skill says: To check the status of your Alarm, say:

“Alexa, is Ring armed?”

That dosen’t work.

Curiously, the skill help page shows this (which seems incomplete and also doesn’t work on my Alexa app):

  • On the next screen, tap Action in the top right corner
  • Tap Add Action
  • Tap Guard and then tap Next
  • Test the routine by tapping the play button icon next to the routine name, or try using the Alexa phrase that you chose for the routine (Example- Say, “Alexa, goodnight”)