alexa arming ring alarm system


i have had the ring alarm system for a year now. Until 2 days ago i was able to arm and disarm just by saying “alexa arm” and or “alexa disarm” and entering my pin. Now when i ask Alexa to arm or disarm its asking for a device name. Have any recent changes or updates changed this?

This is what Ring says about using your voice. I don’t use it this way, so I can’t say if anything changed. See photo.

thanks ,

             I read that earlier as well, but like i said , i never had to do that until yesterday. I mean its okay , just looking for an answer. maybe recent software update.

thanks again

Ok, I just tried it myself. I said Alexa Arm and it did. I said Alexa Arm alarm and it also worked. You might want to remove the Ring skill and then add it back. I didn’t need the word alarm. So it should still work as you said.


 i found the issue. I also have arlo cameras that must of done a recent update or something. it showed up an armable system, thats why alexa would ask me to chose a device. Once i disabled that skill it started to work as normal. so its good to go.

thanks for all the help

Glad you got it sorted out.