Alerts stopped working unless app is open

Hi, any one else found their alerts have stopped working on Apple iPhone? Mine dont work now unless the app is open which is not too helpful. I see some issues with IOS 13 with alerts. I am on 13.1.2. My wife’s iPhone is on IOS12.xx and is working ok as normal. All notifications set to ON and motion detect on etc. in app.


Hi @paulbarnes007 , this may be a better question for our support team. They’ll be able to take a look at your device and settings to ensure everything is properly set up. You can reach them 24/7 at 800-656-1918. Thanks!

IOS13 has added more notification “security”. Check your notification settings and make sure they are on for the app. It sounds to me like your notifications settings are the issue. I remember I had to do some tweaking with the IOS13 upgrade. The fact that your other IOS12 iPhone is working fine and that the notifications work with the app open supports this theory.

Thanks, they are all set to ON, tried phone reset, toggle on/off of settings and all that. Very annoying…

Hi again. If an uninstall and reinstall of your Ring app did not help, I suggest calling our support team as previously mentioned. Thanks!

Hi, deleted and re-installed Ring app and ok now! Many thanks.

1 Like

Fabulous! I’m going to accept that post as an 'Accepted Solution ’ so other neighbors learn what worked for you if they are experiencing something similar :slight_smile:

I’m also having issues. Phone settings are all correct. Uninstalled and re installed, still not getting notifications UGH

Hi, the fix for me was Ring app delete and re-install, this def fixed it.

Did you have to do it more than once? I’ve already tried that per tech support