Alarm devices randomly “removed from system”

I’ve had this issue for months. A while back I had connection issues with all my devices so I reset each one and tried connecting but failed. Eventually got it to work but shortly after would open my app to see that all my devices were missing. In the history it says for each device “removed from system”. Tonight I said enough and tried everything and have dealt with my devices getting removed 4 times in the last 6 hours I’ve been trying to get this to work.

Any help available? I’ve had the ring system for 5-6 months now and during that time I’ve probably only had the system working for a couple weeks. It’s a bit absurd.

Hi @Pyoon. Devices shouldn’t be automatically removed from the system like this. Would you mind reaching out to our support team on this matter? They can pull up your account and take a look at what might be going on and find a solution for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.