Alarm Base Station not Working

I have just purchased and received the 5-Piece Alarm Bundle (for 2nd Generation). The Ring app is already installed on my mobile and I’m trying to add my alarm. I plugged in the alarm base station and also connected an ethernet cable for internet. I don’t see any sign of the alarm panel on my Ring app. All I see on the alarm is an orange light above the reset button. I tried pressing the reset button and the pair button many times and my phone’s bluetooth is on. It looks like the alarm base station isn’t working. Is there anything else I should try or should I just return the alarm kit. Tx

Hi @Robert3000. Disconnect the Ethernet cable, as that is not needed until the Ring app tells you to connect it to your Base Station. Make sure your power cord is plugged in correctly to the Base Station, and try other outlets as well. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.