Adding shared user

I have sucessfully installed my ring alarm and it has been running for a few weks now.
I want to add my son to the app so he can arm and disarm the system if i am not home.
I have gone through the steps to add him, sent him the invite, he has his own copy of the app on his phone, he has responded to my email invite but when he clicks the link to respond all he has is a blank white page with nothing on it. I get no notification that he has accepted or declined the invite. Therefore he cannot be linked to the main account to control the arm/disarm of the alarm system.
Does anyone have any idea of what is going on, i have triple checked ALL settings and they are all as they should be, the invite was sent, then re-sent with the same result for my son of a blank white page when he tries to accept.
Any and all advice appreciated as this is doing myhead in !

Do they have their own Ring alarm/camera system? If yes, see if they use a different email address for you to share with helps. So what they end having is a Ring account for their own system, and a Ring account that you share with.

No he doesn’t have his own alarm system, why would he, he lives with me.
He has his own email address and his own ring account and the app on his phone.
We have followed all steps to add him to the alarm system on his phone but nothing works, all he gets when he accepts my invitation is a blank white screen page. I have concluded that it’s nothing we are doing wrong, it HAS to be a fault with the ring service, all i need now is someone working for ring to sort it out for me.

No one in these forums has access to your account info. You’ll have to call Support (https://support.ring.com/hc/en-us/articles/213608406-Contact-Us).
Be forewarned, wait times are long.

Good luck.

Say what ?!
I don’t want anything to do with my accounf info !
I want to add a user to my system so that person can control arm / disarm functions when i am away.
According to the instructions for doing this, it should be very easy to accomplish but something is stopping the acceptance of my invite going through which HAS to be down to ring and nothing else.

We are just fellow users in these forums, we are not support.
How do you really know what the issue is? You are just guessing at this point. You want a solution, call Support.

In the time you’ve spent posting in these forums you might have found a solution by calling Support.

Hi @IJ1959. First, try having your Shared User delete all emails about being added as a Shared User. Next, delete any Shared User invitations in your Ring app. Now, follow the process outlined in this Help Center article here. This should allow you to add a Shared User. Let me know if this helps.

@ Tom_Ring
I have already done what you suggested, twice, the result is that the invite arrives in my son’s email inbox, he clicks the link to accept, he is taken to a completely blank page where there is nothing, only the URL at the top of the page the rest is blank.
Either the link is invalid or the page it should take him to after clicking to accept has been wiped or deleted.

@ SolarEclipse
I am not guessing at all, the link given to my son to accept the invite does not work, it’s not a guess, it’s a fact. The link is invalid and links to nothing but a blank page with the URL at the top, therefore it has to be an issue with the ring web site or the server is mis-directing.

Hi @IJ1959. In this case, I would suggest using an alternate browser or computer/phone/tablet to try and load the page. If you are still having this concern after trying that, you’ll need to reach out to our support team to investigate this. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

I re-sent the invite to my son a few days after i posted and he told me that everything worked fine.
He used the same browser and email client as before, nothing was changed except the link he was given actually worked. I still maintain that is was a faulty / non-existent link sent by Ring to my son and was rectified “in the background” because it suddenly worked a few days later.
Yes he does know what he is doing as we both work with computers daily and i build and repair them, he also designs and builds web sites so we know our way around a pc / laptop.
I heard NOTHING from Ring on this issue even though i reached out to them directly, they never returned my call OR replied to my emails, not a good look for them !

Hi @IJ1959. Glad to hear you were able to add a shared user.