Ad a new used stick up cam to my network

I have bought a “new” used ring stick up cam. When I go through “set up a device” in my ring network, everything goes perfectly fine except that I don’t get asked to enter the network password. The review confirms that everything is OK and ready for use. At first it may appear that the camera is checking for updates , but after a few minutes it goes offline. I’ve tried factory resetting the camera, but that doesn’t help either. I have searched the forum for related topics, but cannot find exactly this problem. Is there anyone out there who could be so kind as to help me?

Hi @user31495. Are you asked to enter your WiFi information or select a network from a previous setup when going through the setup process? Try entering your WiFi information manually. As a test, you can try connecting your Stick Up Cam to a WiFi hotspot to see if that will allow your update to complete. Once the update is complete, you can change the WiFi network. Let me know if this helps!

I am asked to choose a new network to connect to, i.e. my own. I now tried to connect to my hotspot wifi, the Stick Up Cam connected fine to the network, it started to update, then it went offline again. Exactly the same as it has done before. It seems something happens when the device is about to upload an update. Is there anything else I can do?

Hi @user31495. Thanks for the update. Since your Stick Up Cam is not connecting to any network, I suggest reaching out to our support team to look into this for you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.