Activating problem

Hi, I was a happy owner of a ring stick up camera.

However since one week, I can’t have a video signal. there’s a message “activating device…” and nothing happens. My wifi signal is fine, signal strength says RSSI-55, battery 100%. I have set up device many times…nothing. Any ideas…? Thanks for your help.

Greetings, L

Hey @lucospock ! With an RSSI of -55, there is some indication of potential signal interference. Check out our Community post about RSSI to for tips on improving signal strength.

Another great step might be to uninstall and reinstall the app on your mobile device. Please let us know how this goes! :slight_smile:

I’ve tried everything and nothing really works. When I reset, it works but then fails again…frustrating. Please tell me what to do, thanks

It sounds like you’ve tried quite a bit to get this working. The best next step would be to contact our support team, at 800-656-1918, for more in depth troubleshooting. I’m confident, they’ll be able to assist in resolving this concern. :slight_smile:

Yes, I guess I will do this. Thanks anyway

1 Like