"Activating live view..." issue

I found no solution to this “Activating live view…” problem. Live view works 100% on my secondary testing computer that’s sitting right next to my primary computer. On my primary it never gets passed “Activating live view”. Both configurations are the same. Same OS, browser, permissions. This makes no sense at all. Don’t tell me its an RSSI strength issue because its not. This has to be a bug. Anyone has any ideas?

Hi @user12784. Have you tried a different web browser that is still one of the supported browsers? You can find a chart of supported browsers in our Help Center Article here. Make sure your browser is also updated to the most recent version available, and toggle the appropriate permissions off and back on.

If this concern persists, please follow up with our support team at one of the numbers available here so they can explore more in-depth troubleshooting options. If you are outside of the US, please visit here to see how to contact support.

I guess you didn’t see my comment about it being the same browser on both computers. I’m tired of this product.

I can’t even get my flood light live stream working on my PC past few months. They got rid of Windows app, I can’t download all my recordings in bulk without using some API workaround. This is nonsense. Now you guys raise the price of basic plan. I’m switching to Amcrest.

Hi @user12784. I did see you mention that you have the same browser on both computers, so I suggested trying a different browser to see if we can work towards isolating what’s causing the concern. I’m happy to continue trying to help with general troubleshooting support, or you can also reach out to our support team for more in-depth help. Regardless, thank you for taking the time to share your feedback. :slight_smile: