Activating device message

Doorbell, 2nd generation. Been working ok for 6 months. Got a ring on the doorbell, but when I try to go to live view it says “activating device”
My home network, WiFi, upload speed etc is good.
Any ideas plz ?
Thanks, John

Hi @Britishbiker. There are a few variables that affect Live View performance. One variable is the RSSI of the device. You can find the RSSI for you device in the Device Health tile of your Ring app. This Community post here has great information on RSSI and how it correlates to your Live View. Also, this post here has some tips and tricks for troubleshooting Live View. This information should get you on the right path!

You might try downloading the ‘rapid ring’ app. I can’t explain why but it seems like when one app doesn’t work, the other does. I suspect your device is in a deep sleep and needs a good wake up call.

After speaking with a ring support engineer, my new buzz-word is latency.

I had to open/allow ports on my router. I opened tcp ports 15063 - 15064, and live view started working again. Log into your router as admin, and look for firewall or port settings. My router port settings are found under port triggers.

It is good that your device is working for you - but unless you are installing for the first time, or are using a new/different router … if live view ever worked and now it is not, it has nothing to do with the ports. I don’t think ring has changed the ports they are using recently…