Activating Device live feed

Most the time when I try viewing live feed it just shows activating Device and then times out. I’ve moved the wifi extender as close as I can to the doorbell and get a good connection I also bought the ring power pro v2 to hook to my doorbell to send it more power even though the power seemed fine. I also tried resetting my ring doorbell and unplugging my modem. Still have issues loading live feed.

1 Like

Hi, I also have this on just 1 of my cameras. The other one and the doorbell is fine. I have had this system for just over a week and to be honest I am not overly impressed. I have a camera on the outside wall of where my router is and it says very poor WiFi connection all the time. The other camera is a lot further away but just says poor. I don’t understand. It is the better connected camera that is constantly activating not the one with the very poor connection… I am confused. Plus the cameras only pick up about 50% of the motion. And I don’t get all the notifications when it does pick up motion… also, not being able to set the motion zone to the full extent of the camera view is bizarre. Wish I had done a bit more research before buying all this hardware!

Hi there, neighbors! Live view connection concerns are often related to wifi, Ring app, or mobile device variables. The best first step is checking the RSSI shown in your Ring device health in the Ring app. Check out our Community post about RSSI for tips on optimizing this signal. I recommend also visiting this Community post for more steps on troubleshooting live view. I hope this helps! :slight_smile:

It’s been months since the live view worked on my ring doorbell. every time I try live view, a black screen with activating device comes live view this is defeating the purpose of having a video doorbell if you can’t view .

I have the same issue. I insert a fully charged battery and this works fine but after a week or so I stop receiving notifications and cant access live feed. I checked wi-fi and this is good, I thought the battery wasn’t charged enough as it always started working again by changing the battery. Today it did the same thing and I couldn’t connect to live feed, I saw that the battery was at 80% so this wasn’t the issue, I took the battery out waited 20s and reinserted the same battery - presto! I now have access to live feed again and once more receiving activation notices.

I also have the solar charging add on, I noted that it wasn’t connected and charging although yesterday it was connected and charging. When I put the battery back in after 20s as above - the solar pack is now connected and charging again (the battery is at 78%)

It appears that by removing and re-inserting the battery has cured this, it has also re-connected the charging function (shows connected and able to charge) - my question to RING is - Why does removing and re-inserting the battery apparently fix this, surely the functionality will continue until the battery is exhausted?

I had to open/allow ports on my router. I opened tcp ports 15063 - 15064, and live view started working again.

1 Like