A bunch of problems with Pro ringing

I had a Nest doorbell and it worked fine. But I had 4 ring camera and decided to become a Ring household; I bought a Pro Doorbell.

I had a terrible time getting it connected to the internet, but all seems well now. My android app says transformer voltage is good and signal strength is 63. Oddly, the windows app agrees with the signal strength of 63 but says the voltage is 0.0mv. My voltmeter says it is 18.8v.

It connects to my apps fine and gives notification when it should. it just doesn’t ring very well.

  1. It rings (at the doorbell) about 2 seconds after you push it. Sometimes it requires a couple pushes. And sometimes it doesn’t ring at all. When it does ring, it rings at my phone about 2 seconds after it rings at the door bell. Why?
  2. It doesn’t ring my mechanical chime at all. I have not idea what brand the chime is (there are no markings on it all) but it worked just fine with the Nest. Why?
  3. Since the mechanical chime doesn’t work, I put the ring app on a Fire tablet that is always in our great room; figuring that would work in place of the mechanical chime. Initially that worked, but now it shows a notification when the doorbell is rung, but makes no noise. Why?

Any advice on these problems? A functioning doorbell would be nice.
If it won’t work, I am thinking of going back to the Nest. I have it on Craigslist for $50, but so far no takers.

1 Like

I am following because my mechanical doorbell doesn’t ring at all. Had this Ring doorbell at the previous house and it worked fine with an almost identical doorbell.

Hi neighbors. I suggest looking over this Ring Pro Hardwired Checklist here. Chances are, you need to make some adjustments in the Ring app under the General Settings menu to reflect that you have a mechanical chime kit. Most mechanical chime kits are compatible, but there is an off chance yours is not. The compatibility list can be found here. Let me know if this information helps!