3rd Generation Stick up Cam (Battery version) and does not have the snapshot feature

Good Afternoon, I have a 3rd Generation Stick up Cam (Battery version) and it still does not have the snapshot feature. I have 2 other older Stick Up Cam’s and the SnapShot option is working under Device Settings. I have uninstalled the Ring App on my phone and re-installed and I still do not see the Snapshot feature for the newer Stick up Cam. I am on an Annual plan for all 3 devices.

Hi @kbrown2207. I would recommend you reset your camera and reconnect it to wifi. This will prompt the camera to do a short update and it should have the Snapshot Capture Feature available. To reset your camera, press and hold the setup button for 20 seconds, then release. You can then reconnect it to wifi.

If the Snapshot Capture is not there after performing a reset, reach out to our support team for the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

Thanks I will give that a go.

mmm tried that using the bar code setup and reset and it still doesn’t show snapshot as an option even after a 15 min internal software update. Why is it so difficult when my older versions automatically had the option appear. I will need to try again when I have more time. :frowning:

Still no joy. At least it now shows as a 3rd generation stick up cam battery. But no snap shot option is appearing within devices.

Thanks for the update on this, @kbrown2207! I’ve just tried personally with my Stick Up Camera and IOS mobile device. Here are the steps that got me to the Snapshot feature:

  • Open the Ring app
  • Open the Ring app main Menu
  • Select Devices and choose the Stick Up Camera
  • Tap the Device Settings tile under your Stick Up Camera page
  • Select Snapshot Capture from the list of options, and you should be able to alter the feature from there.

If you are absolutely not seeing this option in your Ring app, please reach out to our support team using the links above. They will be happy to take a more in-depth look at this for you! :slight_smile:

Solution after speaking to the Support Team :

  1. Go to Device Settings and then General Settings
  2. Remove This Device - at the bottom. This does not affect your Ring Plan.
  3. Set up a Device, Security Cams and then scan your cam code.
  4. Flashing light may not work, so you have to press red re-set button on your cam.
  5. Pick up BB again
  6. Then you should see snapshot as a option under Device settings.

Hope this helps someone.