3rd Gen Stickup Cam Camera Preview Tiles Not Updating After Firmware Updates

After my two 3rd Gen Stickup Cams installed the latest firmware update, they are very infrequently updating their preview tile on the Dashboard of both the Ring app (both Android and iPhone) and Ring website.

Both of my Stickup cams are in Wired mode and not battery. I first noticed this issue on my ‘Front Yard’ cam earlier this week where the tile image in the app was several hours old, or “Camera Previews Not Available” on the Ring website. My other Stickup Cam (‘Side Yard’ running the older firmware) did not have this issue, and was still updating the image every 10 minutes like it always has.

I checked the firmware versions and the Front Yard camera having the problem was on firmware cam-1.15.12100 while my Side Yard not having the issue was on firmware cam-1.14.12800.

Yesterday my other 3rd Gen Stickup Cam received this firmware update. That camera is now too not updating the preview tile in the Ring apps.

I have several other Ring cameras of various models and all of those are showing a recent image, updating every 30 or so seconds across all Ring apps. I’ve attached screenshots showing the firmware and RSSI values

I never understood why these Stickup Cams, when in Wired mode and have all the other functionality of a wired camera, only updated their thumbnail image every 10 minutes instead of 30 seconds or so like wired device, but now it’s not even that frequent.

The app tile image seems to update when motion is detected but it’s very sporadic at best if a period of time lapses with no motion: Right now my Front Yard in the Ring app is showing an image from 3 hours ago while the Ring website shows “Camera Preview Not Available”

I should mention that all motion from both of these cameras is being recorded perfect and fine. Live View also loads immediately on both and without issue.

I also don’t believe this issue is related to the other threads about the preview tile not updating in the Ring apps. I think this is a different problem since all of my other cameras are updating fine and this seems tied to a firmware update.


Hi @5150Joel. Is this perhaps related to this concern here?

Thanks @Tom_Ring but I don’t think Legacy Mode is the issue at hand here. I’m able to immediately open Live View from any PC/Chrome Browser and all Android and iPhone mobile devices. Likewise, both of these 3rd Gen Stickup Cams continue to record motion fine. The Dashboard image on these 2 cameras is not updating timely on any browser, from any PC, or any mobile device, Android or iPhone. The image only refreshes every few hours or so.

The problems without doubt started after the above-mentioned firmware updates and seems to only affect the hybrid battery/hardwired cameras. I have 8 other cameras (all various models, but not the 3rd Gen Stickup Cam) that continue to work fine with the Dashboard image timely updating every 30 seconds or so.

If anything, my issues are more closely related to this thread:

I saw nothing in the above thread though mentioning, or tying this problem to a firmware update. Both of my 3rd Gen Stickup cams refreshed their Dashboard image every 10 minutes prior to installing this firmware.

I am having the same issue/similar recently with all 7 of my 3rd Gen stickup cameras that are all powered. Both the App(Android) and Dashboard are updating very infrequently. It can go hours without updating. If I look at the timeline for each camera the snapshots (set for 30 seconds intervals) are also missing so I assume this is related. I have tried various fixes like resetting the camera, disabling/enabling snapshots, etc. The closet I have got to it “somewhat” functioning is to change the snapshot interval on every camera to 3 minutes. It still isn’t consistent but the snapshots do show up more frequently in the timeline although there are still gaps where it isn’t working. I checked and all my cameras are on cam-1.15.12100. I have also confirmed that all cameras are in legacy mode.

@Jeff_G good catch regard Snapshot Capture!

My snapshots are not updating or present on the timeline either UNTIL either another motion event is triggered, or I open Live View. Then all missing snapshots since the last video event are uploaded to the timeline in the app. I’m not seeing any missing snapshots for today between motion events–they’re all there. It seems though the camera is not uploading any snapshots now until the next video event occurs, be it motion or live view.

I have my Snapshot Capture set to 30 seconds on both of my 3rd Gen Stickup cams. Please try opening Live View for a second where the snapshots are missing then close it. Wait a few seconds and see if your missing snapshots then appear on your timeline.

Amazing these firmware updates are pushed out to thousands of devices without being tested.

Is anyone at Ring looking into this and can development be made aware if not? Can Ring rollback the firmware to cam-1.14.12800? Bad enough these wired cameras only refreshed the Dashboard image every 10 minutes but to show images several hours old in the app or not at all on the website is unacceptable.

Hi @5150Joel. I’ve sent you a private message about this concern.

Has anyone found a fix for this yet ?

Any updates from Ring on this issue? This has been occurring since at least Jan. 30th and is directly tied to firmware update “cam-1.15.12100.”

At this point, if they can’t figure out a resolution can they at least push the previous firmware version (“cam-1.14.12800”) back out so our cameras work as they should again?

We do not have any additional information at this time. Tom has already forwarded this information to the appropriate team. Whenever we have an update or additional information to share, we will share it here.

Any updates on this yet?

I since had a need for an additional camera, so I purchased another 3rd Gen Stickup Cam because I needed pan/tilt. As with my other 2, it worked fine until the firmware updated. Three of my cameras are now crippled since installing firmware “cam-1.15.12100.”

Unacceptable Ring can push out this obviously untested firmware without consequence that breaks camera functionality and not resolve it.

I can confirm that my Ring Floodlight Cam Wired Plus running firmware version “cam-1.15.12100” is having this same issue where the dashboard does not show the latest snapshot, regardless of the Snapshot Capture frequency setting. Most of the time, it is stuck at the snapshot from hours ago, but my other devices (e.g. Doorbell and Floodlight Cam Pro) automatically updates to the latest snapshot when I start the Ring app. The only way to get the dashboard to update is to manually load the live view, exit the live view, and go back to the Dashboard to see the latest snapshot. I have tried resetting, power-cycling, turning off/on snapshot capture, resetting the wifi router and even disconnecting/connecting the device - no luck. Just FYI, the RSSI for this floodlight is 44, and the live view loads within a second of opening it - definitely not a connection issue! This appears to be an in-device issue that should be fixed!

My other Pro devices are running firmware version 11.0.XX and are not experiencing this issue. Surprisingly, my other Stick Up Cam Battery running “cam-1.15.12100” is not having this issue…

Any updates on this yet?

Any idea if there is an updates on this yet?

I’ve not heard a thing, and the issue is not fixed either. My 3rd Gen Stickup Cams for the most part only refresh the Dashboard image when motion is detected.

Hey neighbors. I have forwarded this information to the appropriate team, and rest assured, they’re actively looking into it. We appreciate your patience, and if you have any other questions in the meantime, don’t hesitate to ask.

1 Like

2 months now and still unable to view updated thumbnail on Dashboard for all my 3rd Gen Stick up Cam Wired. Come on Ring, you are better than that. Tom_Ring please send me a private message so I can respond. thank you

I have this same problem with the same firmware. I am able to get it to refresh on the iOS app but not consistently. Usually one or the other of my 3rd gen stickup wired cams will not refresh using the app either.

I have seen some improvement recently. It looks like several of my cameras have updated to 1.16.12700 and the snapshot feature is functioning correctly and the dashboard is updating. I still have two cameras running 1.15.12100 and the snapshot and dashboard are still broken. As far as I know there is no way to force the cameras to upgrade so I guess we just wait.

Hello. I’ve been having issues with (2) of my Ring Stickup Cam (3rd gen) cameras. I’ve called a few times to Ring support and they continue to troubleshoot the issue with no real fix.

I noticed almost two months ago now that my 3rd gen cameras were not notifying me of motion. When I go to each camera and view the event history I can see the camera detects the motion but does not record the motion and in turn I don’t receive notifications. So out of 10 motions detections, I’ll receive one notification of that motion. I’ve even taken one of the cameras offline since it’s not notifying me of motion.

The other issues I have is the preview not updating like my 2nd gen camera and ring doorbell. Those two cameras work flawlessly but the 3rd gen Stickup cams are very sporadic.

The 3rd gen Stickup Cam’s are obviously having issues and need to be updated as before. Seems like two months or more is more than enough time to identify the issue. I hope it’s not being seen as an isolated issue.

About the firmware: How is everyone identifying which firmware is actually installed? I don’t see a way in the app to locate the firmware version currently installed. How can it be rolled back to a previous version that works without issue if we continue to have major issues with the camera operating as intended?