3 of 6 devices keep going offline

Hello, I have 6 ring devices but 3 keep going offline. They all 3 go offline at the same time and I’ve tried plugging them into other outlets but the same thing keeps happening. Two devices are indoor stick up cameras and 1 is a chime. They do not come back online until I unplug the power cord then plug them back in. What could be causing this issue?

Hi @user73822. Approximately how far from the wifi router are these 3 devices? What is your download and upload speeds? When your Stick Up Cams are connected to the wifi, what is the RSSI shown on the Device Health page? Having more information will help me with providing relevant troubleshooting steps.

Hello, the first camera says Rssi- 34 and is approximately 10 feet away from the router the other says rssi-60 and it’s about 25 feet away. Both are plugged in to electrical outlets. Download says: 307.69mbps and upload 11.66mbps for the first camera and 264.46mbps download and 10.54mbps upload for the second camera. Thanks

I forgot to list the chime. It reads rssi- 51 and is about 20 feet away.

@user73822 Thank you for that information. An upload speed of around 11 mbps might be a little tight with 6 Ring devices, including any other devices in your home that utilize wifi. Though this shouldn’t impact overall connectivity, such as devices disconnecting from wifi. Is this a Chime or a Chime Pro? If it’s a Chime Pro, and these two cameras are connected to its network, then the Chime Pro disconnecting from wifi would cause the cameras to disconnect.

If that’s not the case, and each device is connected directly to your wifi network, I’d suggest rebooting your router and checking your network settings to see if anything has changed. From there, reboot the two cameras using the reboot option on the Device Health page in the Ring app. Should this issue persist, please give our support team a call at one of the numbers available here. You can also get in touch with our support team on Facebook @Ring by sending a private message.