2nd Gen doorbell not finishing update?

I purchased a brand new 2nd gen video doorbell yesterday. I’ve gone through all the set up fine, connects to WiFi fine but then goes into “update mode” and will not come out of it. I’ve tried resetting the device multiple times and just get the same outcome.
I’ve tried speaking to the customer service online chat who advised me to call a phone number but I have really bad anxiety and talking to someone over the phone is something I struggle to do. Please advise how to fix it?

Many thanks

Hi @AmyLaw. I would also suggest rebooting your router by unplugging it for a few seconds and plugging it back in to see if it helps. If possible, bring your Doorbell into the same room as the router while it updates. If you have tried these steps and are still having the same concern, give our support team a call for further assistance. In the Community, we can only offer basic troubleshooting steps for certain concerns, and if they do not work, our support team can take a deeper dive into your concern.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.