24 Volts at the Doorbell Pro but it’s dead?

I noticed my Ring Pro Doorbell wasn’t generating motion alerts so I checked it in the app and it said it was offline. I checked the device health real quick while I was there and it indicated “last reported” 3970mv and RSSI-38. I went out and checked the doorbell and the white LED circle I was expecting wasn’t there. It looked dead so I pressed the button to see if it would at least chime. Dead. I popped it off the wall and checked the voltage directly at the Doorbell with my multi-meter and had 24 volts. Any ideas for next steps?

Hey @VKSheridan! The power supply and the last read Device Health definitely looks sufficient. Removing the Pro from wires and reattaching it is a great first step, which it sounds like you’ve completed. Next, I recommend performing a hard reset on the Pro by pressing and holding the setup button for 20 seconds, while the Pro is attached to the wires at the door of course.

If this does not improve the functionality of your Doorbell Pro, our support team would be of the most assistance as it may require some in depth troubleshooting.

I reconnected and got the blue LED to flash on the upper half. I did a hard reset and the white light briefly showed and then it returned to flashing blue on the upper half of the button. I have support on the phone now. They’re asking for pictures of the Power Pro installation that I did months ago and a picture of the LED so they can determine what’s going on. Me thinks the battery has croaked and it’s in an unhappy state… :frowning:

UPDATE: Ring Support has concluded my Ring Pro Doorbell is dead and will issue me a replacement.


I have the same issue but I’ve had mine working for awhile, at least a couple years. Is there a reason why these stop working?

I went through the steps, checked for 24v at the bell, disconnected the power, reconnected it, it goes white then beacons blue in the upper half then just stops responding altogether. I’ll have to contact RING support in the morning then.

After doing a bunch of reading, it appears the Ring Pro has a small 300amh battery in it to keep it energized while the doorbell button is depressed and that battery has a tendency to fail. If the battery fails, the doorbell basically becomes a door stop. Some users have replaced the battery and got their device to operate but it’s not an easy task. Google “Ring Pro Battery Replacement” and you’ll see what I mean.

Just for giggles, I replaced my transformer to a 24VAC 40amh to ensure no excuses for power supply (and confirmed at the doorbell wires) but that didn’t help. I recommend you contact Ring Support and see if they offer a replacement. They’ll ask for pictures to ensure you have a Power Pro kit installed as well as pictures of your doorbell L.E.D. indications (if any) so be ready. Good luck!

My Pro was randomly going dead a while back and I replaced the transformer with a 16vac 30 VA model. Still had problems. I decided to disconnect the mechanical chime in my house and called about the Power Pro Kit V2 for bypassing my current chime. I was met with a “Why do you want to do that?”. I tried to explain the power problem I was having and got nowhere. I made my own Pro Kit V2 and it has worked well for about another year. Now I am having the same problem with it randomly going dead. I bought a new Pro today and was going to install it, but a new problem has arisen. It seems I am not alone in that it appears a possible firmware update has suddenly made my doorbell extremely sensitive to motion even with the sensitivity set to people only. I am having second thoughts about installing the new one.