Ring Video Doorbell

Browse posts, comment, and join in the discussion about Rings wired and battery doorbell.
Ring Doorbell Two Way Talk Not Functioning

We are having an issue with several iOS devices (iPads and iPhones) where we intermittently can’t hear people at the doorbell, and they can’t hear us talking into the iOS device at the doorbell. We are having this problem with an older Ring Video Doorbell 3 and a brand new Ring Doorbell Battery Plus that we purchased to try and solve this problem.

We are pressing the buttons in the app to enable two-way talk and we have allowed microphone permissions in the app. This was working fine for several years up until about two weeks ago.

We can make the audio work temporarily if we restart the iPad and or cycle the app’s microphone permissions off and then on again on the iPad. Restarting the doorbell doesn’t help. I just now tried disabling Bluetooth on the iPad and this did make it work - not sure if this will keep it working or if it’s still going to stop functioning again in an hour or two. There were not currently any Bluetooth devices connected to the iPad when the issue was occurring, however.

We have tried factory resetting the iPads we are using and confirming iOS and the Ring app is up to date with the latest version from the App Store. We have also tried resetting the wireless networking devices and rebooting and doing factory resets on the Ring doorbells. We even bought a brand new Ring Doorbell Battery Plus to see if that would resolve the issue, but it didn’t.

At this point I am fairly certain this is a software bug, either due to an iOS change, a Ring firmware update, or a Ring app update, but I wasn’t able to get anywhere with Ring support.

Is anyone else having this issue?




28-05-2024 05:28:37

Responses (3)


Update: turning off Bluetooth on the device didn’t seem to make a difference. We still lost sound after about an hour.


28-05-2024 06:35:05


Hi @user82773. Have you tried using the Two-Way Talk feature on Ring.com? What specific model iOS devices do you have, what iOS is installed and what version of the Ring are you using? Also, what is the RSSI for these devices? You may need to make some changes to your router, as these also have updates from time to time and this can affect audio.


30-05-2024 01:48:44


Original poster here - Not sure why I can't log in to the Ring Community with my old username or where our other responses in this thread went, but the technical issue seems to be resolved. Nothing we did seemed to help, but at some point over the last couple days it just started working again so I assume the issue was identified by Ring and fixed.


11-06-2024 07:12:18


Hi @user_75b6bf. Apologies for any confusion, we recently made some updates to the Ring Community, and we're still getting everything in order. I'm glad to hear the issue you were experiencing has been resolved! If it crops up again, feel free to update in this thread. 


11-06-2024 07:30:12

Didn't find an answer ?

Log in or create your Ring account to post a question and join in the on the conversation.

Most Helpful Members