Ring Video Doorbell

Browse posts, comment, and join in the discussion about Rings wired and battery doorbell.
Ring Doorbell 3 fails to configure - two white led's on left side

My battery video doorbell is one year old and started disconnecting and going off-line.
I have disabled and removed it from my device list (deleting all the data) , and now trying to add the doorbell results in the same error each time with two white LED’s lit on the left side - failed to configure. I can see from my firewall that the doorbell is connecting to DNS and communicating with fw.ring.com but fails to complete the registration with ring.

I have a tp-link deco (mix of M9 and M5) mesh wi-fi but have set up a guest network on 2.4 ghz only and disabled fast roaming and beam forming. I have three chimes, and two disconnected at the same time as the doorbell but using the app to remove and re-install has them back working (solid blue light).

I can see from the deco app that the doorbell connects to wifi, and I can see via my firewall the traffic going between the doorbell and ring servers. The doorbell is unmounted from the door and sat next to a tp-link M5 disc and in setup shows a strong green signal for the guest wifi network.

The doorbell goes into setup (white led’s rotating) and connects to the app, allowing the wifi network to be configured, but then the app shows a progress bar and the doorbell switches from blue flashing to two white LED on the left side before the app completes registration. The app eventually shows the white led patterns - and the doorbell will go back into setup via the app.

I suspect either: 1) removing the doorbell from my device list has caused it to be blocked by ring or 2) the doorbell has got a broken config (corrupted software/update) and fails to negotiate.

Any ideas? (Not keen on buying a new ring doorbell)

Update: I see that the act of removing the doorbell has severed the link between my ring plan and the device. What is the best way to proceed - 1) cancel the plan and start again 2) ask ring to register the device (as setup fails to do that)




15-12-2023 08:45:22

Responses (2)


Hi @user71385. Check your network settings to ensure the ports and protocols used by Ring devices are on. Then reset your Doorbell by holding down the setup button for 20 seconds. After the reset is complete, try walking through a new setup in the Ring app. If the Doorbell still does not complete the setup, please give our support team a call at one of the numbers available here. Your concern may need to be escalated, as it deals with advanced network troubleshooting. If you are outside of the US, please visit here to see how to contact support.


19-12-2023 04:26:07


It worked for a year and then it didn’t . I have resolved the problem by replacing the ring system.
In my opinion Ring needs to improve it’s WiFi stack to work with modern mesh systems.


19-12-2023 10:29:48

Didn't find an answer ?

Log in or create your Ring account to post a question and join in the on the conversation.

Most Helpful Members