Ring App

Browse posts, comment, and join in the discussion about Ring app features, settings, and more.
S
Unable to login on Ring App
android
cs-support
Hi, Whenever I try to login to the Ring App on my Android phone I always get the message that an invalid email or password was used. It does not prompt for additional authentication. I can login via a browser using the same email/password. I have managed to create a new user and login that way but it is not the owner so no access to chime. I have cleared the cache in app, reinstalled the app and reset my password however it still informs me that an invalid email or password was used. I do receive an email that my account was signed onto a new device. Any suggestions welcome. Regards, Jose

37192

0

14

02-01-2022 12:45:35

Responses (15)

M
Instead of just deleting the cache, try deleting the app data too. If you uninstall, there will still be remnants of the app, deleting the data ensures a clean install. Mark

0

02-01-2022 06:42:03

T
Hi @SecretWombat. What is the OS version that you have installed on your Android and what specific model phone is it? What version of the Ring app is installed? Also, can you share a screenshot of the error that you are getting? I would also ensure that you do not have an active VPN on your phone, as this may be causing an error. Once I have this information, I'll have a better idea of how to approach this concern.

1

04-01-2022 05:28:17

S
Hi, I'm running Android Version 11 (RRFS31.Q1-59-76-6) on a Motorola Moto G50 and using v3.47.0 of the Ring app. The phone is not running any VPN and I have cleared cache/deleted app data and reinstalled the app with no luck. The following screenshot is the only error I receive when I try to login. ![Screenshot_20220105-170349|225x500](upload://4FhmCiVlJ2070G5OwLhHHDluuAZ.jpeg) I also receive an email with the following text "Your Ring account was signed in to on a new device or browser. Here are the details: • Device/App: Ring Community • January 05, 2022 at 4:59 PM UTC † • IP Address: 81.107.**** • Country: GB †Coordinated Universal Time (UTC) may not represent the sign-in time zone." However there is no prompt for a ring verification code. If I create a new login then I can login to Ring and see my camera the only problem is that the account I have problems with is the owner so other accounts are limited in what they can do. Regards, Jose

0

05-01-2022 05:12:24

T
Hi @SecretWombat. Thanks for sharing that information. Here is something you can try. Login to Ring.com and navigate to your Dashboard and then to your Control Center. Once on there, go to your Authorized Client Devices. Now, remove all of your Client Devices. Client Devices are all of the devices that you have used to log into your Ring account with. Removing them may allow you to login to your phone. You can learn more about this [here](https://support.ring.com/hc/en-us/articles/360038142272-Ring-Control-Center-Information). Let me know if this works!

0

06-01-2022 07:44:54

H
I have a iPhone 13 with same issue and switching off my VPN cleared the login issue. Thanks Tom_Ring. The solution button tick box is missing so I could not accept this fix. Cheers

2

21-05-2022 07:04:04

C
Hi @Hideme. I'm glad that suggestion of turning off your VPN resolved this for you! :)

1

23-05-2022 03:54:07

U
FYI, turning off the VPN did the trick. You can turn it back on and still get notifications but having issues connecting to the app

1

21-08-2022 03:41:44

S
HI @Tom_Ring . I removed all client devices and I still get the invalid email or password message on my phone. When I logged in to ring.com via a browser it prompted me for a ring verification code as expected which I do not see on my phone. Regards, Jose

0

06-01-2022 10:00:56

T
Hi @SecretWombat. Thanks for giving that a try. At this point, I think someone from our Level 2 Team of Neighbor Solutions Experts should take a look at this. They'll be able to deep dive and find out why this is happening. Please give our support team a call at one of the numbers available [here](https://support.ring.com/hc/en-us/articles/213608406). If you are outside of the US, please visit [here ](https://support.ring.com/hc/en-gb/articles/213608406)to see how to contact support.

1

07-01-2022 04:16:51

R
I have encountered the same problem.

0

13-01-2022 11:47:36

N
Same is happening with me on iPhone running on ios 15.2. Whenever I try to log in to app it says invalid credentials and and not let me log in. Whereas with the same credentials I’m able to log in to browser. Tried uninstalling and reinstalling app many time but problem persists. Would really appreciate the support.

2

19-01-2022 03:57:33

Didn't find an answer ?

Log in or create your Ring account to post a question and join in the on the conversation.

Most Helpful Members

W

windracer

1

User
Solution

J

Jventerprises

1

User
Solution

U

user_3c8999

1

User
Solution

U

user_d52f2e

1

User
Solution