"Works With Ring" Zwave Devices no longer sync to Alexa

I have a number of Leviton Z-wave switches that appear on the “Works with Ring” list.

I’ve been gradually adding them throughout my house for some time now, and historically whenever I’d add a switch to the Ring app, it would automatically be added to the Alexa app, almost instantly.

I recently added a new switch (same model as my others) and this one has not been discovered by the Alexa app. I have also been unable to manually add it through Discover my Devices.

The switch can still be controlled through the Ring app, but this adds limited utility as voice commands, room groupons, etc cannot be used.

It would appear there is some issue between Ring and Alexa where new devices are no longer syncing properly.

1 Like

This is a growing issue but no one seems to be able to help. Ring support directs to Alexa support. Alexa support directs to Ring support. Seems to be related to some type of issue with the Ring Skill app.

Parallel thread: Connected z-wave devices not being discovered by Alexa - #2 by Justin_Ring

1 Like

Hi Neighbors. Hey neighbors. Thank you for bringing this to our attention. We understand that we may need to dive into this concern. We’ll need you to call our support team so that we can create a ticket for this issue. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Another option is to send us a private message on Facebook @Ring. Thank you for your patience while we investigate this issue. If you have any other questions in the meantime, don’t hesitate to ask.

1 Like

Having the same issue. Z-wave devices that you connect to the Ring Alarm Pro used to automatically show up as available devices in Alexa. These Z-wave devices no longer show up in Alexa and it seems there is no way to add them to Alexa. You can see the Z-wave devices in the Ring app and control them there, but without Alexa you’re unable to automate any of those devices.

I called and spoke to a member of the Ring support team who seemed to think this was just the way it was going to be. That any old Z-wave devices would be “grandfathered”, and new devices would need to be wi-fi based and “Works with Alexa”. I really hope she isn’t correct about this.

1 Like

I just bought a Ring Alarm and was wondering why I could not see my added Works With Ring Z-wave devices in Alexa. I hope this can be fixed soon since this is the main reason I purchased the Ring Alarm. Was a ticket ever created or is the answer now “that’s how it is”?

1 Like

The person I spoke to didn’t even give me an option to open a ticket. What good are “Works with Ring” devices if you can’t automate, set schedules, create routines, etc? This doesn’t make a whole lot of sense to me.

1 Like

Hi @joeker03. Whenever you call Ring support, a ticket is automatically created after you have been verified. Rest assured, our team is looking into this concern. Thank you for your patience while we work to resolve this.

Okay, thanks Tom. I called again yesterday and spoke to another Ring support agent. They told me since the devices are showing up correctly on the Ring app, this would appear to be an Alexa issue and that I should contact Alexa Support.

The Alexa support person I spoke to tried to have me add the devices to the Alexa app via the manufacturer’s app and link those skills to Alexa. That process doesn’t work for Z-wave devices. Z-wave devices need to connect to a Z-wave hub. In this case the Ring Alarm Pro base station is the Z-wave hub. I tried to explain this to the Alexa agent, who couldn’t understand the difference between a Z-wave device and a WiFi device.

All the previously linked Z-wave devices show up in the Alexa app as “connected via Ring”. New Z-wave devices added to the Ring Alarm Pro base station simply do not show up as devices in the Alexa app. How do we get new Z-wave devices that are connected to the Ring Alarm Pro base station to show up in the Alexa app again?


Having all the same issues stated in this thread. I wonder if the March 29th update has anything to do with this


I ran into the same issue where z-wave smart switch connected through Ring base station wouldn’t show up on Alexa. Hope someone can look into this issue soon!


Having the same issue! I spent 90 minutes with Amazon customer support with no luck. I use GE smart dimmers and when I try to connect them via the “works with ring” feature under security and scan the QR code, the app sits in a seemingly endless spinning state until I restart it. The device is still added on the ring side but not on Alexa. If I connect the device without scanning the QR code I can make it through the setup process without it hanging but it still doesn’t show up in Alexa. I would also be very frustrated if this is the new way of the world for Ring!! I have never had this issue with these same devices in the past.

Same issue here. Tried three agents with Amazon and none were able to resolve.

@Tom_Ring I have called Ring support multiple times and it only leads to ring support requesting to unlink then relink the Ring skills app from Alexa to discover new devices which results in no new devices found. The support call ends with “I will now connect you to Alexa support as there is no issue within the Ring system”. Alexa support provides the same procedure which has the identical result and concludes with "You need to contact Ring support as there is an issue with the Ring skills app not linking Works with Ring devices. I had no issues adding the same GE Z-Wave switches 1.5 weeks ago. Something changed in the last week. Please provide elevated support status on the issue.

1 Like

@Tom_Ring this is very frustrating! Possible you could follow-up with Ring support on this issue or have somebody contact me?

Just hung up with Ring support…

Last week I added another Z Wave switch to my alarm (not the Pro). Switch added and works fine, and is actually the same model as two other switches I’ve had for about a year. Alexa can’t discover or find this switch.

Called support as directed above. He stated they are aware of this issue, but it’s an Alexa problem since it works fine in the Ring app… so it seems we’re still at the back and forth where neither will accept responsibility.

Replying here for visibility of the issue. Problem is said to be resolved per below post:

Alexa is still unable to find my new ZWave switch though.

Hi neighbors. As mentioned above, this issue has resolved with a backend fix. If you’re continuing to experience this issue, ask for Alexa to discover your devices again. If that doesn’t work, try removing and re-adding the devices. Should this concern persist, you’ll want to follow up with our support team to further investigate this. Our support team will be able to get this concern escalated to the appropriate team so they can gather the necessary information. Once again, we appreciate your patience and your continued feedback.

1 Like

Same here - nothing fixed. Still can’t find newly added switches

@Caitlyn_Ring This issue is NOT resolved. Alexa continues to not discover new Ring connected ZWave devices. Until either Ring or Alexa owns the reported issue, the cycle will continue.

@Caitlyn_Ring @Tom_Ring Confirming this issue has not been resolved, new zwave devices are still not showing in Alexa.