Won’t connect to new network

I’ve changed my wifi and my ring chime pro and ring doorbell will not connect. It’s ring doorbell 4, I’ve fully charged the battery and it still won’t connect.

My router is near the doorbell and in the same position as my previous one. I’ve even tried to uninstall the app and start again. I’ve followed all steps suggested through the support pages but nothing is working. Is there anything else I can do? Thank you

1 Like

I have exactly the same problem, I am following any answers/suggestions.

When I try to set it up my WiFi doesn’t show on the Wi-Fi options?

I have just a changed to Virgin with a hub 5, the battery ring cams, doorbell and chime all connect fine. The plug in indoor cams don’t :woman_shrugging:

Today received my new Doorbell Pro 2 and have completed the installation process. I am now attempting to setup the Doorbell but cannot complete the task because the Wi-Fi network “Ring- f471f4”is not connected to the Internet. I was told to allow Wi-Fi Assistant to switch to a better Wi-Fi network and I followed the described process. However, the Doorbell then finds and establishes a connection with my home Wi-Fi system but then never completes it’s process of connecting with the Ring Doorbell to complete setup. I viewed the video that was offered but the video is so small that I cannot read the text.

How can I get the doorbell to connect with my home WiFi system?

Hi neighbors. If your Ring device is not connecting to your WiFi, try the following steps:

  • Factory reset your Ring device by pressing and holding the setup button for 20-25 seconds.

  • Reboot your router by unplugging it from power for a few seconds and powering it back on.

  • Verify your wifi password is correct. You can test this by forgetting your wifi password on your phone and reconnecting it. If your phone does not reconnect your wifi then your wifi password is wrong and you will need to contact your internet service provided for further assistance.

  • Try doing your setup in the same room as router if possible.

  • Try completing your setup with another phone or tablets using the same account from the original phone.

  • Verfiy that your router settings meet what the Ring devices need in order to connect and operate correctly.

We also have this Help Center page with other steps to try. If you have tried these steps and are still having the same concern, reach out to our support team for further assistance. Give our support team a call at one of the numbers available here.

Did this start working for anyone? I got a new router with even faster Internet speeds from BT. Basically since plugging it in only the Ring outdoor cam (battery) has stopped working. All other devices are perfectly fine including my Ring doorbell (battery). I’ve tried all troubleshooting and it isn’t working. Can I get a replacement as a plus member?

Hi @PlasticPigeon. If the troubleshooting steps in the marked solution didn’t help you connect your Ring Camera to your new wifi network, please follow up with our support team for further assistance. They can run through all applicable troubleshooting steps with you, and determine the best solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.