Wired ring stopped working after broadband change

Ok guys so I’ve been tearing my hair out for the past 5 days on this. I’ve tried Ring customer service who have given me some direction but it’s not happening.

So my wired ring doorbell was working fine but we recently upgraded from Virgin Personal broadband router with a dynamic IP to a new Virgin Business broadband router with a static IP and the doorbell has stopped working.

I’ve tried to set things up again from a hard reset but I just get stuck in a loop - app connects to the ring ssid, app connects to the wifi, app then tries to connect to the ring ssid again but fails.

I’ve tried:

  • hard resetting the doorbell many times
  • connecting to 2.4 only on the router
  • Setting a static IP on the ring
  • Adding the MAC address to allowed devices on the router
  • Adding firewall rules as per ring website

I have no idea what’s going on and I’ve tried everything. Any ideas?

Hi @WillySetJet. You may need to adjust some settings in your phone. Try checking your settings for a WiFi assist/Smart Network Switch and turn that off. Sometimes, this setting can cause issues when connecting to the Ring network. Let me know if this helps!

1 Like