Windows 10 App does not delete videos

I’ve been using the Windows 10 Ring app from the windows store for 1.5 years to manage my recordings. The app still lets me view the videos, but I can no longer delete unwanted videos. Does anyone know what changed? I’ve tried resetting everything on my computer, but to no avail. This is a very frustrating occurrance. Any assistance anyone can give would be appreciated.

Same problem. Have latest Windows 10 updates and Ring app update from MS store. Can delete items using Android phone app but not with Windows 10 app. Frustrating. Hope someone has a solution :smileyvery-happy:

Hey neighbors! Could you attach a screen recording of what happens when you go to delete a video as you normally would on the Windows PC app?

The attached video is composed of screen captures stitched together into an MP4. Had to compress to ZIP so system would accept the file for upload. Hope you can unzip and play it.

First screen – opened History/Activity screen

Second screen – selected event to delete

Third screen – pressed delete

Fourth screen – no change, event still there.

Can close and re-open app and event is still there, nothing gets deleted. The only way I’ve found to delete an event is using the Ring app on my Android phone. Not sure if this is exactly what OP is experiencing.

BTW - 2FA for Community is a pain :confounded:

@FreddyP You’re amazing for this! I was able to download that video, and thank you for taking the time to do this. I actually went on my Windows PC and was unable to delete by selecting as well. We do have a trending concern that we are investigating right now where neighbors are unable to delete multiple events at once, so it’s possible since you are hitting select, and then selecting what to delete, even though it’s “one event,” it is during the “delete multiple mode” per say, which is why it’s failing.

Are you able to actually go to the Windows 10 app > History > and then right click on an event and hit delete that way? I tried that out, and that worked for me instead! Let me know.

@Chelsea_Ring – Yes, going to the Windows 10 app > History > and then right clicking on an event and hitting delete allows me to delete one item at a time.

The problem sure seems to be related to the “select” action, even for a single event. At least the temporary workaround of right clicking and deleting means I won’t have to go to my phone to manage the events! Hopefully your coders can find the issue and make corrections. The bulk delete using Windows 10 app on laptop makes managing events so much easier.


I can confirm that I can delete individual events as described above. It must be related to the multiple delete command. The multiple delete method is the only way I’ve ever deleted anything in the Win10 App.

Awesome work here neighbors! Thanks for working with me to isolate this concern. I recommend to use the Ring app on mobile to delete multiple events in the meantime, or right clicking on an event in the Windows 10 app will delete it for now. I have my team that works on the Windows app isolating this right now and working on a fix. I will make sure to update you all when this comes about. :slight_smile:

It looks like the mass delete feature is working again. Was there an update to the app? If so it worked.

1 Like

Hey neighbors! It looks like we release a fix for this on Monday, and confirmed it to be working as it should today. If you could, please test this and verify that it is working for you. :slight_smile:

@freed1976 Thank you for verifying it’s working for you now too! :smiley_cat: