Wifi password typed incorrectly RING DOORBELL 2

Hello, my ring doorbell 2 is giving me an error message that says that I entered the wrong password for my Wi-Fi router. I checked many times and I know the password is correct and I followed all the troubleshooting tips, reset my Wi-Fi password, factory reset the doorbell, and it’s still giving me the same error message.

1 Like

Hi @XRP123! This should not be happening, especially after changing your wifi password. I recommend creating a 2.4 ghz guest network on your router with standard settings, a simple SSID, and password which do not contain any special characters or spaces.

During the final step of the setup process in the Ring app, when choosing your home wifi to connect to, there is an option to Add a hidden network. While your network is not hidden, this option allows you to manually enter your wifi information. This may help to resolve your concern. Feel free to let us know how this goes! :slight_smile:

Mine has started to do the same today.

I have not changed any passwords, and i am in a constant loop trying to re-connect it…

Hello,

I’m experincing the same issue.

I have not changed any passwords and it has suddenly started to do this…

I wouldnt even know how to create the guess network as you have suggested to XRP123!

Please help as this shouldnt be happening surely and should connect to your wifi without creating a new one.

I have my also connected via a Charm device - and is doing the same with this on or off…

1 Like

we have had a device fitted for around 2 months now with no issues.

however today we have noticed that it is not allowing us to connect to Live View and it states Ring is no longer connected to the internet.

i have thus followed all the instructions in regards to having to try and establish the connection but i am in a constant loop of it stating i have entered the WIFI password wrong.

This is not the case, i have never changed our password and still the original via the sticker at the bottom of our Virgin Media hub 3 device.

i have done everything possible but it is not rectifying the problem…

Can someone please help?

1 Like

Hi @IanUnHan. If the previous troubleshooting steps suggested in this thread are not helpful in resolving your concern, you’ll want to follow up with our support team directly so they can look into this further for you. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Having similar issues. Nothing changed with wifi after it having wirked successfully without hithc for a few months. I am now stuck in the loop trying to reconnect a ring 2 doorbell andit keeps giving me the wrong passowrd error when i know it is right.

We are experiencing the same problem. We haven’t changed our WiFi password, however our Ring doorbell has disconnected and keeps telling us the WiFi password is wrong, it isn’t. Going round in circles here.

This is now happeneing to me as of today. With so many people having the same issue, and the password credentials are entered correctly why is there no resolution from Ring? The issue is clearly on their end.

I am now having this issue as well after noticing I didn’t have an alert for 2 days. Can’t do anything to fix it. Will just be buying a new camera from a different company as this is my second Ring to die.

Having the exact sameissue. After working for about 2 months, the password error comes up no matter which network I log into and all passwords have been validated as correct.

I just called the help line and here are a few fixes:

  1. Select the device having issues and scroll down to device health. Select “Reconnect to wifi” or something similar pertaining to the wifi network connection. Follow the prompts to reconnect. If this method does not work try these other options.
  2. Reboot your router and see if the devices automatically connect. If they do not then follow the device health and wifi reconnect instructions.
  3. Make sure the Ring app is up to date and reboot your device that has the Ring app on it.
  4. Hard reset the cameras/ doorbells by holding the orange button on the back for 20 seconds at least instead of just tapping it.

I had three devices go offline at the same time.Naturally I assumed it was my wifi but there seemed to be no issues there. What actually worked for me:
First I tried the “Device Health”, “Reconnect to wifi” method which did not work. Then I tried to hard reset my device by holding down the orange button on the device for 20 seconds followed by rebooting my wifi. Finally, I restarted my phone (which is where my Ring app is installed) and two of my three devices had already reconnected. At this point, I tried the “device health” method to reconnect to wifi on my last remaining device and it finally reconnected. Hope this helps! I will try to watch my email for any other questions anyone may have.

1 Like

Has anyone resolved this as I still have the same issue ? I had tried every step which is above and still not working.

Update: I hard-resetted the device and connected it again which has worked.

To reset your device - hold the orange button for 15 seconds. You know you have resetted it if the device says “Welcome to Ring” or something like that.

Hope that helps.

1 Like

This resolved my problem and got my doorbell back online on the first attempt. Like @Szygy mentions in the post, it seems to be a combination of factors at play.

  1. Check app is at latest version.
  2. Shut down phone running app.
  3. Reboot all network devices, modems, routers, ect…
  4. Wait for Wireless network to come back online.
  5. Start phone.
  6. Press orange button for 20sec. (it will try to connect to old network, if that fails proceed)
  7. Launch app and try ‘Device Health’, I changed networks again.

Your password should work at this point!
Thanks

1 Like

I worked for an hour trying the troubleshooting steps. Called customer support. On my ring doorbell the reset button is an orange button on the back. Held it down for 20 seconds and was immediately able to reconnect to Wifi

1 Like