Wi-Fi net work pwd not recognized during 2 GEN indoor plug-in set up

I’ve been trying to connect my 2nd Gen Ring indoor plug-in camera. Every time I get to the very end it recognizes my network but after that says Wi-Fi password is incorrect. I had a friend test my Ring on her network with her password doesn’t work either. Same error. I tried it on both 5G and 2.4G. I called customer service they promised to send me a new one. It has been over a week. I couldn’t wait so I ordered another one from Amazon. Same issue. Anyone has any suggestions?

Hi @user56701. I would recommend verifying that your wifi password is working for any other devices, like your phone. You can forget your wifi network on your phone and rejoin it to check to see if your wifi password works. If your phone does not reconnect to your wifi with your password, then you will need to contact your internet service provider for help with your wifi password. Try also completing the setup by temporarily disabling the wifi on your phone and using Bluetooth by selecting the option to do so when it appears in the Ring app during setup. If you have tried these steps and are still having the same concern, reach out to our support team once more to further investigate.

Thank you! I have tried it all except Bluetooth

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.