Virgin media hub 3 issue

Hi,

I’m trying to get my Ring doorbell to connect to my new router I used to be with Sky with no problems

I’m with Virgin Media and got a HUB 3
I’ve tried researching doing all online says like change advanced settings such as changing name for 2.4 ghz connection and trying to connect to that independently this didn’t work
Tried changing channel of 2.4ghz this didn’t work
Tried resetting my hub (by the reset button) didn’t work
Switching off and back on
Tried rebooting my ring doorbell (pressing orange button for 20 seconds)

I just cannot get it to connect
I’ve tried making a guest network to connect to

Tried all above steps MULTIPLE times

None of these work and that’s all I can find online to do

Any help would be appreciated

Thank you!

I am with Virgin and had some problems getting wifi in certain areas of my house. I complained to Virgin (which is not easy to do) but eventually they gave me a couple of boosters. One is plugged into a socket outlet and connected to the modem by an Ethernet cable. Another is plugged in near my TV box and that is connected to the box with another Ethernet cable. This help and is not far from my Ring doorbell which I think may have helped the wifi signal bing received by the doorbell. I hope this helps. Good luck.

Hi @user74549. Those were all excellent steps to try to address your concern. We also have this Help Center page with other troubleshooting steps you can try when your Doorbell is not connecting to your wifi. If these do not help, give our support team a call for further assistance.