Video feed not working - always stuck on "Activating Device"

The ring gets stuck at “activating device” and rarely ever shows me a video feed. It seems to be at rssi - 70, and if i recall correctly, we tested the speed to be 2.5mb upload and 5mb download. Help!

I have the same issue, where someone rings the doorbell and when I select live view it stays on “activating the device” good RSSI 69 and voltage is above 4.0

The last time my live view worked was December 17, 2019. I too have been in contact with customer service several times with always a different “fix” for the problem to no avail. I even purchased a new wifi router thinking that would help, but no luck. The app only shows activating devise and online live view just has a black screen. This device is only 1 year old and I am very disappointed with the results.

download the rapid ring app - it seems to be much better!

1 Like

Live has not worked via iPhone app nor iMac app since 5/4/20 after 3:40pm Mountain time. I have working history prior to 5/4/20 3:40pm MT, but nothing after. I see all of the alerts/motions in the history log, but they are not clickable, they will not launch a video. All of the ones prior to 5/4 launch fine. Something happened on or around this date to RING. I am not the only one experiencing this issue. And when you call customer service, they want you to do all sorts of ‘waste of time’ troubleshooting like resetting your router and pulling your doorbell off the wall and completely uninstalling and resetting it. WHAT!?!?!?! NO. This has worked almost perfectly for years, now all of a sudden tons of customers are having live/video issues and your solution is to run them in stupid troubleshooting circles? Be better. Or I will just find another more reliable brand. Anyone else seeing this crap? Everything is working except for live. My motion alerts work and log. My doorbell actually rings an audible sound when pressing the button. I see “live views” in the history, I just cannot access/click on them, nor can I launch live. So if everything else is working except for live, why on earth are these guys wanting me to tear it all down and reinstall. Ridiculous.

Power Source: Hard Wired

Power Status: Very Good

Signal Strength: RSSI-52

Firmware: Up to date

RapidRingApp: Does not work either

Ring Team - when you are you going to admit you have a LIVE issue and fix it? Additionally, why is the RING Community team removing my REPLIES about this LIVE issue on other members postings about the same issue? You are saying it is “spam posting”. Do please contact me and educate me as to how me REPLYING to other members to let them know I am having the same issue is spam posting. I am not starting multiple threads (which WOULD be spam). I am REPLYING to other members having the same issue. Is the problem that you don’t want to admit there is an actual issue with LIVE and don’t want your members talking about it and connecting the dots? Why else would you remove my posts, Ring team? This is a FORUM, right? Am I actually not allowed to REPLY to other members created threads that I am having the same issue? Really? REALLY?!!?!?!?!?!?!?!?!?! Another nail in the RING coffin. Do we have your actual attention on this matter yet? Also, there is this crazy little thing called process of elimination for accurate troubleshooting. If my RSSI is good, my connection is strong and literally ALL OTHER FEATURES are working in my RING, except for LIVE VIEW, how could this possibly be an issue on the homeowner side? Baffling you guys would not realize this.

live view just stopped working for me too. it has to be something on there end.

Mine live view is MAGICALLY working again now, after over a month stuck on “activating device” and black screen, while ALL other alerts/motions were working the entire time. Low and behold there was a RING update on 6/8. There have been no changes to our network or anything within our setup. At all. Period. What a mystery Ring. Guess it wasn’t on my end…AS I SAID ALL ALONG. Update and try yours again.