Verifcation codes not working

Not logged on to the web account for some time, now, no matter how many times I try, the emailed verification code is never accepted.
I have reset my password successfully (just in case it was an issue). This meant I needed a verification coded for the Android App - which fortunately worked — but still the verification codes do not work in browsers (tried two) on a Win 10 laptop.
Is there something I am missing or is there a problem?

I just logged in twice with no issue. You can also check https://status.ring.com/ for currently known issues.

Thanks for than, no apparent problems with the status, but still no luck whenever I put in the verification code - it just clears the box, saying ‘this field is required’.
I can log in to this Ring Community page, but there is nothing relating to my Account Navigation from here.
I usually just use the Phone App but had a problem with that this weekend when all devices vanished - it kept wanting me to set up a device as ‘no devices are installed’ - even though I was still getting movement alerts on the phone and I could view them!
Remedied after logging out and back in on the Phone App, but I still can’t log in on the Web App.

Hi neighbors! @r6kmb Thanks for sharing the status page, it’s always a good idea to check there first whenever you’re experiencing any concerns. @andrewnicholls Make sure you don’t have any VPNs enabled and if possible, try to sign in on a different web browser to see if this concern persists. If it does, I would recommend reaching out to our support team so they can take a closer look for you and help resolve this. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

I have the exact same issue starting at the exact same time as the initial. The verification code is emailed to me, but upon entry, it refreshes the screen indicating nothing entered in the field and that the verification code is required. This is via Chrome (my regular browser) but it is resolved if I use a different browser – which I do not want to have to use just for one misbehaving site. Maybe Ring has something it can update, since all of my other sites work fine in Chrome?