Unsecured network?

Well, here goes—this is my first ever post. My initial setup of two Ring 2020 doorbell cameras along with a Chime Pro a few weeks ago went off without a hitch. But after renegotiating an Xfinity contract which involved a new router modem as well as a new SSID and password (God help me), my Ring devices now will not reconnect to the WiFi network. Before the final “Something went wrong” message appears, there is a brief notice that says, “Security policy prevents the use of unsecured networks”. (?) My new WiFi network is still using the recommended WPA2-PSK security mode and I can’t find anything obviously wrong here.

After fitting the description of a crazy person by trying the same potential fixes over and over while hoping for a different result, I give up. What do I actually need to do to get these devices working again? I realize that other people are having similar problems, but I haven’t noticed anything specifically about unsecured networks. Thanks.

Hi @pizano. I reached out to my team about this message you’re getting and it may be due to some settings on your phone. You can check out this article on how to disable this secure wifi notification on Android devices here. If that doesn’t help, you may want to try setting your devices up on a different phone or tablet to see if that works.

Should this concern persist, I would suggest reaching out to our support team at one of the numbers available here. They’ll be able to take a deeper look for you since you’ve already done a lot of basic troubleshooting. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Caitlyn, thank you for your reply. I tried your first suggestion by forcibly stopping the secure WiFi feature and clearing the cache on my fancy Samsung Galaxy S20 Ultra phone. But the phone failed in its mission to connect my Ring devices to the new WiFi network.

However, I then tried your second suggestion by attempting to connect the Ring devices using a different device, in this case an old, slow and cheap Samsung tablet laying around the house while not expecting much success. But for whatever reason, the tablet succeeded in connecting the Ring devices to the new network, so everything is back in business once more.

It’s yet another case of something working again without me fully understanding why, but I’ll take what I can get and hope for the best. Thanks again.

1 Like

I too have the identical problem with my Samsung S20ultra (Android11, Sky SR203 Router) and the inability to install devices with the same ‘Unsecure Network’ messages as above. Had the same problem with my S8+ and an older router too, so is a long term issue.
I can work around it by using an old Samsung Galaxy S5 phone for any installing. Works fine after that.

I don’t have this issue with any other products or apps.

Ring need to detail a work around for this issue.