Unable to connect Ring Chime

I am facing issue with Ring Chime device, please advise.

  1. There is no pulsing blue light in front of the Ring Logo when plugged to an outlet.
    2.in my mobile - under wifi network unable to detect chime network.

Please advise on a faster resolution tip

Hi @Renjithg. Give the following troubleshooting steps a try to see if you can get the Ring Chime up and running in the Ring App:

  • Test a different power outlet with another device to ensure it works, and then plug the Chime into that outlet.
  • Reset the Chime by holding down the reset button on the side for at least 15 seconds.
  • Attempt to set the Chime back up in the Ring App after this with the steps under Set Up a Device.

Once the Chime is set up in the Ring App, you can find steps on how to link it to your Ring Doorbell or Camera in our Help Center Article here. I hope this helps! :slight_smile:

I, too, have this issue. And none of the advice works - unfortunately you have left out the fourth step when the 15s reset doesn’t work.

It’s a Chime (1st Gen) and has no pulsing blue light. I have never really used it since I bought it - it’s been powered off.

I have tried three different power outlets. I have held the reset button for more than 15s. Never see a pulsing blue light.

It does seem to be doing something though - I tell the app that I can see the light (even when I can’t) and it asks me to join the Chime network. As usual, my iPhone tells me it’s unable to join the network.

I have tried disconnecting from my WiFi network on the phone, switching WiFi off/on on my phone, and still it won’t connect to the Chime, nor does the Chime flash its light.

/Brett

Hello! Were you able to make settings?