Trying to use Echo Show 10 gen 3 as a Ring bridge

I read the [articlehttps://support.ring.com/hc/en-us/articles/360059329551-Using-your-Echo-devices-as-a-Smart-Lighting-Bridge] , but I get struck at the part where I get this message “Please enable the Ring Alexa Skill for your Echo Show 10”

The Ring Skil, is enable in my Alexa account and link with Ring & Alexa, but how to I **“enable for your Echo Show 10”? **

I don’t see anything in the Ring Skill or Alexa for doing that. I did enable Sidewalk on the Echo Show 10 gen 3

Glad you asked, @Reenie! It sounds like you are doing everything correctly in linking your Ring and Alexa accounts. The step in question is requesting you to add the Ring skill, or enable the skill, in your Alexa account. To do this:

  • Open the Alexa app on your mobile device.
  • Tap the More menu button at the bottom right corner.
  • Select Skills & Games from the menu.
  • On the next screen, search for Ring in the search box.
  • After you’ve found the Ring Skill , tap the Enable button.
  • Alexa will ask you to sign in to your Ring account.
  • Once you enter your Ring account information your Ring Skill will be linked to Alexa again and you’ll be asked to discover devices.
  • Tap Discover Devices .
  • All of your Ring devices should appear and be connected to Alexa automatically.
  • If you don’t want Alexa to integrate with a particular Ring device, simply select the device and tap Forget on the right side.

If you need further help with this, here is our help center article for troubleshooting Ring Alexa Skills. Once complete, proceed with the steps in the help center article you mentioned to use your Echo device as a Smart Lighting Bridge.

I hope this helps! :slight_smile:

I have the same problem
Suggested issue doesn’t resolve it.
Tried the following :

  1. Enable / disable Ring skill
  2. Obviously linked amazon and Ring accounts
  3. Updated version on Echo 10 and Alexa app
  4. Factory resets on hardware and reinstall apps
  5. Confirmed WiFi network same and enabled Bluetooth
  6. Tried multiple devices (Ring, GE, Samsung)
  7. Tried to add from both Alexa app and Ring app.

Still get the same error message that you did.

Had 5 different Amazon tech agents and same trouble shooting but can’t seem to resolve. Guess just return the units.

Same issue here. Called Ring support and the agent had me uninstall and reinstall the app twice, reboot my phone, try a second device, etc. Finally she gave up and said “it must be a problem with the Alexa app - you need to call Amazon”. I asked her to at least open a bug ticket with the Ring engineers to look into it, and she said “Sorry but there’s no error code so there isn’t a bug”. I finally convinced her to leave the ticket open.

FWIW, I’ve tried this with both an iPhone 11 Pro running iOS 14.6 and a Samsung tablet running Android 11. Stuck on same screen on both devices.

Echo support told me they raised a ticket for also and said I’d hear back within 48 business hours after the Amazon techs/engineers could review….and it’s now 96 hours later. Starting to think they just told me that to get me off the call and never actually raised a ticket.

I received the A19 Bulb for free with and Echo 4 Device,
Tried every troubleshooting in the book.

  • Resetting the light (Turn on and Off 6 Times)
  • Disable/Enable the Ring Skill
  • Turning off/on my phone
  • Using other Devices (I tried 6! Yes, 6 other Devices, iOS and Android)
  • Changing the Address
  • Contacting customer support (Ring and Amazon)

But nothing works for such a simple light this is to much trouble, To be hones this is my first Ring device and I was planning to purchased even more since the echo 4 has the built in bridge (have a little crush on the ring door bell for a while) but at this point I’m considering my self unlucky that I didn’t get a Sengled smart bulb instead, which I have 3 since I purchased 3 echo dots, and not a single one of them give me troubles, just connect them and synch them, I don’t know if this a know issue but I really hope that Ring solved it quick…