Trouble setting up built in Echo Show 10 3rd gen bridge

Hi. I’ve spent a lengthy amount of time on the phone with support today and have gotten no where. I see there was a post from someone in this group spring of last year talking about how their path lights only worked with Echo Show 10 bridge so that gives me hope. The echo show 10 shows the camera feed when asked, but doesn’t turn my ring floodlight on. When I tried to do the set up for my ring spotlight in the Ring app and selected Echo Show as the bridge, I got the message: “Please set up a compatible Alexa enabled device. To do this, open the Alexa app, set up the device, then add the Ring Alexa Skill.”

Everything’s on the same WiFi, the echo show is up to date, I’ve disabled and enabled the Ring skill in the Alexa app several times, my devices (Echo and Ring) all show up in the Alexa app-ring spotlight being the obvious exception. Has anyone had success setting up this built in bridge? I returned a Ring bridge I initially bought and never opened and got the Echo show instead mainly because ring articles and sales reps said it could act as my bridge as well. I also liked the idea of the screen and voice controlling my lights with Alexa. If the main feature doesn’t work however, it’s got to go back. Both Amazon products so it’s not making sense for it to be this difficult.

You’ve likely already followed the steps in the Help Center article below, but there are also some great tips in there.

If your Echo Show is still not allowing use as a Ring Smart Lighting Bridge, our support team can take a closer look for you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

Thanks. I followed the steps in the article. When I call support, I get the same kind of suggestions that don’t really help: disable and reenable the bridge, update everything, etc… Is there a particular team within support i can ask for directly?

Same. Still no luck. Up until today, they still haven’t figured it out.
Still doesn’t work with my show 10 (3rd gen).