Successfully get instant view on alexa show from doorbell

Just got this to work this past weekend…

First add a routine to alexa

Then choose device ( doorbell name)

Next choose (you have the option of doorbell rings or senses motion)

Add “Custom” … typing “show me the (named view like front door)” (this will auto add alexa, to it)

Next choose which device(s) to show on.

It’s been working good… I chose motion because it still takes a few seconds to connect and motion should occur before anyone actually gets to the doorbell.

1 Like

Hi @Jvk-of-md. Thanks for sharing this tip! I’m sure it will help lots of neighbors!

Is there a way to control the duration? I’ve got the live feed displaying on Echo Show using Routines but it now causes the camera live feed to stay on for a long time if I don’t close it down with a voice command. Could this be limited to 30 - 60 seconds ?

1 Like

Great question, @Phimi! By design the triggering of a live view from the Ring app, or a supported integration, will result in a live stream that lasts for a maximum of 10 minutes or until the live view is ended. This is not the same for other events such as motion or rings from button push, in which these events would only record for the standard or set recording length duration. At this time, live view duration is not something that can be altered, other than by manually initiating/ ending the live view as intended.

As we always value our neighbors’ feedback, feel free to add this request on our Feature Request Board. This way other neighbors can share their interest in one place, that we can organize and share with our teams here. :slight_smile:

1 Like

Create a second routine that also triggers when the doorbell detects motion, then add the wait action and set it to how long you’d like the live view to display. Then add a custom action after that to stop the live view: “stop” or “go home.”

Hopefully at some point they’re able to integrate this functionality into the Ring skill.


I actually just figured out why my Echo Show 5 was not showing or announcing the front door ring doorbell despite my configuring everything correctly. Note that NO ROUTINE IS NEEDED. This is built-in.
MY ISSUE WAS that I had DO NOT DISTURB on and I never realized it! It was not the button on the Echo that mutes the mic. That would have been obvious. There is another DO NO DISTURB feature in you can set on the screen or in the Alexa App! I had never seen that. Once I disabled that, it all works again!

1 Like