Streaming Error

Hi has anyone else having issues when I’m trying to open live view via cellular connection all I get is the streaming error message. The live view I’m trying to see gets recorded and I can view the history. I’m using an iPhone 7, my wife is using an iPhone 12 and is able to get live view without any problems so it can’t be signal strength etc. I have a number of cameras and a door bell that all show the same error message.

Hi there, @Elphaba! Good call on trying out another mobile device, as well as checking for the Live View recording in your history. This is a great sign that your Ring devices are working as intended. As live view is recording and working on at least one mobile device, this narrows down that possible cause to be mobile device connection or another similar variable.

Please ensure there is not a vpn enabled on your mobile device, and try test live view connection when using wifi connection only, or cellular data connection only, on the mobile device. I recommend giving our Rapid Ring app a try, as it is designed for the quickest access to live view. I hope this helps! :slight_smile:

Hi Elphaba, I have 3 ring devices seperate location and my iphone 12 has the same issue displaying streaming error. This has only happened recently. Not sure what to do.

I have this problem too with iPhone 12. Started about 3 weeks ago (early august2021). But it only seems to exist on Three UK network. I have tried using a VPN on the Three UK network and the live stream works. Live stream also works when roaming and also using Wi-Fi networks, so this seems to be a Three UK/Ring compatibility problem.

I have exactly the same problem on my Iphone 12 pro max which is on the Three network but on my work mobile which is on O2 everything is fine

Try connecting another device to your iPhone12 through the personal hotspot, while that device is connected, try the Ring live streaming on the iPhone12. This made it work for me yesterday. Having a device connected through the hotspot should be unrelated to what is going wrong, but hopefully it will help someone to troubleshoot this if the same is happening with your iphone12.

Also related are the following threads:

1 Like

This issue appears to have been fixed. Whatever either Ring or Three did during October 2021 seems to have fixed the issue.

My live view went bad when Ring terminated the windows app. Up until then it worked fine on my iphone 12,ipad, ipod and P.C. I don’t have an android device. Now it is hit and miss. Sometimes it works and sometimes it does not on any of the devices. I does not matter whether it is wifi or not. It seems to not work more when you need it most as night when people are prowling around your property. Pretty tough if you cannot see what is going on. In my case the internet connection is strong, this appears to be some sort of software issue. I have re-attached my devices without effect, deleted and re-installed the app on all devices without effect. Tried it from the ring.com website without effect. When it does not work, it does not work then for no apparent reason it comes back and works for a couple of hours then goes out again. Ideas on what to do are welcome.

Same problem here. Don’t know when it started. Checking everything on my network, but all ok. Seems to be a problem on mobile connection only.

I found a solution! Please check and response!

Every time I have two SIM cards activated (1 physical + 1 eSIM) the Live Stream failed. Deacativating the eSIM, so I have only 1 SIM actual active, the Live Stream are possible.

Edit: 1eSIM and deactivated physical SIM also works.

Stream works with only one active SIM!