Stick Up cam won’t power on


Suddenly my stick up cam won’t power on at all.

I run it off a single battery and have done for about 18 months.

I charged the battery as normal, put it in and it won’t power on. No flashing light underneath or anything.

I also have another camera and video doorbell so I tried the battery in the doorbell, it works fine.

I took the battery that is currently in the doorbell and put that in the camera, nothing.

I tired the other battery slot in the camera, nothing

I tried holding down the button on the top for 20 seconds, nothing.

No network changes have been made or anything so I’m at a total loss why this has suddenly just died. We even have decent weather at the moment!

Any help would be appreciated, tried calling support but are now shut at this time :frowning_face:

1 Like

Hi @Bedders1. It seems like you’ve tried the basic troubleshooting steps I would recommend. If you cam is completely unresponsive, please follow up with our support team. You can also get in touch by sending a private message @Ring on Facebook or Twitter.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.