Stick Up Cam and Solar - Camera not detecting Solar Panel as "Solar", but as "Electrical Socket"

Hi all

I have a Stick Up Cam latest version and Solar panel set up in my garden for a few weeks now.

Im having issues with the camera running out of battery in a day, i bought another battery to see if the orignal one was faulty but its the same with the new batttery too.

When I connect the solar panel into the camera, Power Source Says “Electrical Socket” in the app and cannot see any where it say Solar

Purchased this from Ring direct on Aug 31, 2020 (https://en-uk.ring.com/products/stick-up-security-camera-solar)

ive tried resetting the camera from scratch, solar panel is facing the sun in the day time. iver changed the settings so it only records motion and no live view so help it not use a lot of power to no avail.

im a bit lost now, is the solar panel faulty?

any help much appreciated

Thanks

Hi @Antec. It sounds like you’ve done some great troubleshooting on your own, thank you! In this case, I would contact our support team to look into this for you. Please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times.

Thanks. Is there is a UK email support email address I can use? Would help me greatly. Thanks.

OK. Ive changed the power source to battery and now what I can see is in the day the source changes to electric socket and I can see the charge symbol. And at night it’s changes to battery.

But no sign of anything solar anywhere in the app in any of the menus

Is this how it’s supposed to be?

Hi @Antec, happy to chime in for Tom here. The charging symbol does indicate that the battery is receiving a trickle charge, which is consistent with what the Solar Panel provides. It would not provide a trickle charge at night, as there is no sunlight reaching the Solar Panel. For any follow-up on this concern, please reach out to our support team at one of the numbers available here. They’ll actually be able to look at our account and device in order to see that it’s registering the Solar Panel properly. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times, and there is currently no email support available. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Hi, I just purchased a Ring Stick up Cam and Solar panel.
(1) Does the battery have to be fully charged before initial use?
(2) How can I tell if the camera is detecting the solar panel, does the battery level indicator change when the solar panel is connected?
(3) The solar panel gives a trickle charge during the day, is this charge enough to fully charge the battery?

Hi @CoolE. The battery should be fully charged before you perform the initial setup of the Camera, and it’s suggested to charge the battery for at least 8 hours to ensure it’s fully charged. The Solar Panel will provide a trickle charge when it’s connected which will help keep the battery topped off, but if the Camera experiences a large number of events, it may discharge more quickly than it can be charged. In those cases, the battery will need to be manually charged with the included charging cable. I hope that helps! :slight_smile:

Hi
Just wanted to chip in on the above problems, I’ve had a stick up cam for a year now works ok added a solar panel during summer and the display was electric socket in the day and battery overnight which was to be expected and it did charge the panel… So during last November no charge from the panel (not showing on device health page) and having to change batteries, ring support checked and it seemed the panel so they sent a replacement. After changing over still not good seemed just to be running off the battery, not enough light maybe during the day.
I’ve never had on the device health page any mention of a solar panel but yesterday suddenly I see power source…battery. Battery level…31. Solar status …connected (ring solar panel is connected and able to charge this device)
Has there been an update or something ? I don’t see any charging symbol in the battery Icon on the stettings page which I used too.
So bit confused what we should be seeing now so we know it’s working correctly?