Spotlight cameras won't setup green blinking light

Hello,

I just installed a complete Ring system with all the basics and an indoor cam. I bought a 2-pack of Spotlight cameras, neither wants to connect to wifi with the “green blinking light” error. I have an Asus Zenwifi AX mesh network, the Spotlight cameras are the only ones giving problems. I see them connecting to the network but they end up getting a green flashing light anyway. So far I’ve tried:

Disabling tri-band smart connect wifi settings, only enabling 2.4, changing authentication mode, making a 2.4 guest network, making a 5.0 guest network, disabling all wifi6 related settings, nothing worked. Then I tried to let it connect directly to the modem and did all of the above, same error.

I have two cameras, fully loaded batteries, tried factory reset, reset both the modem and the router, nothing works.

Please help :slight_smile:
Regards, Maarten

Just been on the phone for 1 and a half hours with an American customer support engineer (I’m Dutch, first I talked to a very friendly woman who guided me through the steps I’ve done 50 times already). Main thing we tried apart from what I already mentioned is take a second phone, set up a basic 2.4ghz hotspot on it, and have the camera connect to that. But the problem still exists. He escalated it further up the chain.

If in the mean time anyone has any brilliant ideas, let me know :slight_smile:

Hi, Were you able to find a fix? I am having the same issue. I have a spotlight battery camera that I bought like 6 months ago and never got around to setup. I keep getting the green blinking light, I have tried multiple apple devices, rebooted my router, and even tried with a hotspot, nothing works same green lights. Could this be related to an old firmware on the camera?

I have the same issue trying to install a Ring Spotlight Cam Solar. Goes to green light and then fails. Have tried setting up from multiple devices with no luck.

Got two really old spot light cameras with solar panels that have been sitting in the box for about a year. Tried to set them up today, get the same issues as above, however tech says they can see them but they fail on my end. WTF?

Why can’t Ring during the setup send out the firmware upgrade as part of the setup which would probably fix all of our PROBLEMS!

I even tried setting up my laptop as a hot spot, connected to my 2.4GHz router. I have verified that I am on only a 2.4GHz connection. My Phone, the hotspot and cameras are literally ON TOP OF EACH OTHER and when I follow the setup, the app connects to the temp Ring Hotspot, then connects back to my hotspot. The problem is, when the light is green (which I would expect to be success), it sits there blinking the app on the phone is sitting there spinning. When the green light finally stops blinking, the app then asks what color light do I have? If I answer what I had, it fails back to the beginning. Definition of insanity happening here, “Repeating the same action over and over and expecting different results”!

My question is what is the success color if I am wrong on green. There is Red (Error, wrong password), Blue (??), Green (Success??) and White (??). If I answer a different one, will it succeed?

HELP!!!

Im having same issue bought new spotlight cam and get flashing green light when it trys connect to wifi. I have tried seperating my wifi to just 2.4ghz connection still had same problem.

FYI - got an email from Ring this morning that this issue has been fixed. Installed Ring Spotlight Cam and worked right away.

1 Like

Hi neighbors! If your Spotlight Cam is not completing the setup process or is not finishing a firmware update, please try the troubleshooting steps below:

  • Attempt the setup process on a different smartphone or tablet if you have access to one. You can find more tips for failed setups in our Help Center Article here as well.
  • If you have a Spotlight Cam Battery, ensure the battery has been fully charged using the provided charging cable before attempting the setup process. It may take about 8 hours to fully charge the battery.
  • Reset your Camera by holding down the setup button for at least 20 seconds. After the reset is done, attempt to set your Camera up in the Ring app using the steps under Set Up a Device.
  • If you have a dual-band router, try creating a separate guest network that is only 2.4GHz and try connecting your Spotlight Cam to this network.

If this concern persists after trying these steps, please give our support team a call at one of the numbers available here so they can assist with more in-depth troubleshooting support. If you are outside of the US, please visit here to see how to contact support. :slight_smile:

I’m glad I’m not the only one! I haven’t tried it since the last 1 1/2 weeks since I was on the 90 minute call. @rileyfatcat777 thanks for the response, I will try again this week to see if anything changes.

@TheGolgothan I have tried three different modems/routers/hotspots nothing worked. It sounds like forcing a firmware update on first connect with any network would solve the problem. And with the green stops blinking and the app asking what colour I see, I have the exact same problem. Have you tried again after riley said the problem is solved?

Caitlyn thanks for your response but I’ve tried that a lot of times along with the engineer I was on the phone with. Alas, that did not work.

1 Like

Hi @smoefer. I would definitely recommend following up with our support team on this matter then, as it might require further in-depth troubleshooting. I marked my response as a solution in hopes that the general troubleshooting tips and tricks can help other neighbors that may have a similar concern. Feel free to keep us updated on what solution support is able to provide as well. :slight_smile:

Problem solved…! I haven’t received an email back yet about my ticket but decided to try it again after rileyfatcat’s comment about it being fixed and it’s actually fixed. No blinking green light, just a solid green light after 5 seconds and install without a problem. The WIFI is my regular 2.4/5.0 combined mesh network so. Not sure what changed but glad it did!

1 Like