Spotlight cam set up

Hi I’ve recently bought a spotlight cam plus and I am unable to get it to conect to my account , I can get as far as the wait for spotlight cam to enter setup mode, then the light does not flash and pushing the centre reset button does not do anything , either resetting or rebooting ?I’ve been at this for over two hours now . I’m using andriod not sure what else to add

1 Like

today , i am unable to conect to the camera at all, now I get the message " Hmm, something went wrong. please start the set up again

1 Like

Hi @Nige101. If you have purchased the battery version, ensure the battery is fully charged with the provided charging cable prior to setting it up. Next, try fully resetting the Spotlight Cam Plus by holding down the setup button for at least 20 seconds. After the reset is done, attempt the setup process again to see if you’re able to successfully get the Camera up and running. If you run into any error messages or issues, try the steps listed here. If the Spotlight Cam continues to be unresponsive, please give our support team a call at one of the numbers available here so they can explore further options. If you are outside of the US, please visit here to see how to contact support.

1 Like

good morning Caitlyn , the battery was fully charged , I have also tried using a type C power cable it still does not connect , I’ll try the suggested solutions on those links and get back to you with the results

1 Like

nope but getting further


I can see the ring setup , in my wifi and can connect to it

1 Like

but then it tells me I have no internet

1 Like

so then i switch to either 5Ghz or 2.4 Ghz and both fail

1 Like

oh and I am sitting not 4 feet away from the router and cam attempting to set it up before even going outside to fix it to a wall so distance is not an issue and if it is how is it going to work through a brick wall ?

1 Like

mark this thread as closed , I’ve given up on this product, it’s being returned, maybe in a years time when the bugs have been ironed out I’ll try again or switch out the alarm system for a Yale one at least they work

1 Like

@Nige101 Since the troubleshooting suggestions I shared didn’t work and you’re still unable to get your Spotlight Cam up and running, the next step would be to contact our support team at one of the numbers available here for further assistance. Our support team is able to take a deeper dive into concerns than we can on the Community. Of course, I also understand if you choose to return the device.

1 Like

Hi,
I had a very similar issue. I tried it on a different phone and it worked straight away, which was a good test. However I wanted my phone to be the master so I uninstalled the app, did the process again and it worked. My issue was that it had asked for permission to try and find the camera but that seemed to mess it up and it wouldn’t work any way. The second time I did it I selected the alternative that was offered and it went through first time.

Edit: I contacted support and they were no help unfortunately. Just said I had to call the technical team. I think this is simply a bug that appears in a few cases but is hard to diagnose.

1 Like

This post was flagged by the community and is temporarily hidden.