Solar panel keeps disconnecting

I have a spotlight cam that I added a solar panel to. It will randomly change from “connected” to telling me to add a solar panel to “extend battery life.” I know it’s not charging all that great so I’m assuming it’s doing it a lot. The directions show to screw the plug on but my plug looks like a regular jack. There’s no way to screw it in. How can I keep it from disconnecting? Or why does it disconnect, then reconnect again? When it’s “connected,” it seems to charge fine, but it disconnects way too often to be effective.

1 Like

Hi @shiestyho. Does the physical plug from the Solar Panel become disconnected from your Spotlight Cam? Or does the Ring App state that it is not charging? About how many hours of direct sunlight does the Solar Panel receive each day? I’d also recommend unplugging the Solar Panel, ensuring there is no dirt or debris on the plug or the Solar Panel itself, and then reconnecting it.

I’m having the same issues, is directly to sunlight and will say connected and then will say not connected, when I purchased the solar panel it said connected all the time but suddenly I started having this issue

Did you get a resolution to this? Mine is doing the same thing.

I ordered 4 Spotlight Cam Battery units with Solar Panels. The cameras and panels shipped separately and neither box contained the plastic screw-in clip that holds the solar panel charging cord secure on the back of the camera. The instructions show to use this clip but I don’t have it and I don’t want to install and have issues with it coming undone. How do I get 4 of these cord securing clips sent to me?

Hey @Justinunique. If your Ring Device is missing items such as the clips, you can contact our support team to assist you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

This happens to me also. It must be the new batch. I have 2 other ring spotlights with the older solar panels that screw in. Solar has been solid for over a year with zero issues. I got another solar spotlight and the solar constantly goes to disconnected state. I’ve tried rebooting and removing and adding it back and cleaning the port and making sure it’s tight but it seems to be connected for a while then suddenly is not connected. We even replaced the spotlight cam and same issue with that one. The panel is also installed next to the other solar panel we have for our other spotlight cam so it’s not a matter of enough sunlight it charges fine when it’s connected. Maybe there is a firmware update coming soon that needs to happen to fix this bug. I suppose I haven’t swapped out the solar panel yet with ring support maybe that will solve it?

I recently bought the super solar panel for one of my Spotlight Cameras and noticed in the installation video there was no security plug on the back of the connector. I called support because I immediately began having the same issues with the device disconnecting. The installation video shows the old version of the solar panel and apparently the Super solar panel doesn’t come with this adapter. Regardless mine kept disconnecting and Ring sent out a new panel. During the time of shipping my replacement the original panel started working somewhat “decent” - meanwhile I 3d printed a small adapter to keep the plug connected. This appears to have worked however I do still occasionally see the original panel basically doing nothing but this is generally during the evening. I received the replacement Super solar panel and rather than replacing the first panel I installed this one on my second Spotlight camera and figured Ring could just charge me if it worked as I would be fine keeping it. I’ve had the second one installed for about 50 hours and having the exact same issue as I did with the first one. I’m on the phone with support now and they are basically useless…I don’t mean to be rude but I generally try to always escalate the call when I contact Ring. Anyway what I noticed on both of these Super Solar Panels is that the connection will pop off very easily. I mean literally just a bit of pressure on the side of the plug will do it. I ended up 3d printing a small bracket that will hold the connector. I cannot say for sure that this is the actual issue but so far it appears to be the case.

1 Like

johnderek can you make any info available about what you fashioned/printed to keep the panel connected. Is this for the back of the spotlight cam? I can possible get a friend to print as my cameras keep disconnecting but not always a physical problem and sometimes a software issue. Ring support seems to completely lack knowledge about this which is frustrating. Not handy to keep needing to mess with a camera that is 12 feet off the ground. It could be a cold weather issue or maybe wind moving the camera. Just need to find a workaround. Thanks for your post and any help.

Hello John,

I am have having the same issue could I ask you for assistance in getting the 3d printed specs so I can get this printed for my spotlight cam solar too?

I contacted ring on 2 occasions and explained by taking this cable clip away it will also possibly get water into the camera and causes air getting into the connection but they assured me the cameras would work fine but this is not the case.

Any help would be really appreciated from you or anybody where I can get one from or print it

Regards

Parm360