Smoke-CO detector "Device Replacement Needed" while device seems to be operating?

Question

I’m seeing the following. Is this an issue on my side? If so what should I do?

Issue

After the seemingly successful installation of a smoke-CO detector to ring.com, I see “Device Replacement Needed” red letters on both smoke and CO sensors on ring.com.

I do see battery status. I have not tested activating the smoke/CO detection (during the installation, it did beep at the right time).

Environment

I’ve not seen that message myself, but it almost sounds like it is an indicator that the Smoke-CO detector needs replacing. How old is it, or is there an expiration date on it? I believe one is supposed to replace those detectors around every 10(?) years or so.

Thx for a quick reply. As I’ve updated my OP, I bought the device anew 2 months ago on amazon.com. (manufacturer’s note reads replace every 7-year).

I found a “!” sign in each device page on my ring.com dashboard and clicking that shows this message.
2021-12-01_16-56-51_ring.com_smoke-detector-err

For search purpose, the msg reads:

Replace with a new First Alert Smoke & CO Alarm.
This device is malfunctioning and may not reliably detect smoke & CO. This device will no longer be monitored.

Just spoke with ring.com tech support who eventually escalated to their “advanced support” but they saw no more details than what I posted here and recommended talking to the manufacturer.

1 Like

Resolved myself. In a nutshell,

  • I have 3 devices of the same kind. 2 out of 3 successfully connected to my ring.com.
    • However, connection process for those 2 successful ones got stuck a few times. I did factory-reset this device (*1) multiple times AND forced to remove the device from ring.com and re-tried.
  • 1 failing device, which is the one I reported on this thread, is still not connecting to ring.com.
    • Status of it in case anyone is curious. After various attempts I reported above, I did try to connect the device to another home automation system (Home Assistant, via Z-Wave JS Mqtt) just to see if the device’ Z-Wave inclusion works. This went successful, then factory-reset and re-try to connect to ring.com, which then complained that the device is already included in another Z-Wave gateway. This indicates to me that factory-reset may not be sufficient, but the manufacturer said the factory-reset step I did sounds ok, and I’d have to rather talk to ring.com support.

So I’d call the original issue on this thread is resolved.

*1…Instruction isn’t clear at all. I found sliding the battery cartridge out, remove batteries and put them back in, press and hold Test button, slid the battery cartridge in, them release Test button.

2 Likes