Smar Lighting Bridge constantly disconnecting

My ring Smart Lighting bridge has begun dropping offline nearly constantly. Often I get two notifications nearly instantly that it’s down and then up. Wifi signal is great. I’ve tried all of the troubleshooting advice I’ve seen in the numerous other posts of people unable to resolve this issue with no luck. I even changed my modem/router and then tried a wifi extender in the same outlet as the bridge. I’m a quarter mile from a neighbor so I don’t think it’s an interference issue. This is the straw that has me looking at other products. It’s clearly a firmware bug with numerous people having the same issue for more than two years and no resolution.

Additionally, in the app there is a firmware version number, which indicates according to Ring documentation that the device is not up to date. But it never updates.

Hi @Jkwilson. Typically a wifi extender should be installed at around a halfway point between the router and the Ring Bridge. Having the extender too close won’t solve the root cause if the router itself is far away, since the extender will then receive the same connection that the Bridge is receiving. What is the approximate distance between your Ring Bridge and your wifi router?


I’ve tried reinstalling numerous times with multiple devices and even tried a new router. It’s not working at all now because after taking 10 tries to connect to wifi, it’s hung on the message “Ring Bridge is preparing itself for use” and it won’t go further. This after spending two weeks getting a stick up cam to connect after a power failure with many of the same issues. Something is fundamentally wrong with the app or the devices. Numerous people here and other sites have the same problem that never gets resolved. I wish I’d never started with Ring.

Hi @Jkwilson. I’m happy to chime in here. Since you have covered the basic troubleshooting steps and are still having the same concern, our recommendation would be to contact our support team for further assistance. They should be able to take a more in-depth look at your concern and figure out the next steps to take. Give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

@Jkwilson @Justin_Ring I am experiencing the exact same issue. Takes mulitple times to connect then gets stuck on the message “Ring Bridge is preparing itself for use” and it won’t go further.".
Has this been resolved?

Hi @ygoncho. As Justin_Ring has mentioned, the steps covered here are the basic troubleshooting steps. If these do not resolve your concern, you may need to reach out to our support team.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.