Shared users cannot see the doorbell and status does not changed from "invited"

trying to figure out how the hell to add a shared user to my Video Doorbell to get motion sensor notifications and doorbell rings as well as access to historical videos

1- I created a shared user and sent the invite
2 - my wife received the invite fine in her email
3- its by no means obvious that the link she receives is inviting her to “create an account” but that’s what I had to do.
4- once you click on the button in the invite you basically have to “reset the password” because it does not offer that option as part of the" accepting invitation process" it just asks you to login which you cannot do as you’ve never set up a password before.
5- I’ve reset her password and she now has an account! great NOW WHAT???
6- Her phone is not linked to our doorbell. and the invite status on my account still says “invited”
7- I have an option to SCAN THE BARCODE on the doorbell. _ Sod that!! I’m not unscrewing the device from the wall!!!
8- anyway that’s not the option because if you do the shared user wants to take over the “ownership” of the doorbell device!!!

I’m an IT Professional and if I’m struggling to do a simple task of adding the ring doorbell device to multiple users in my household then I don’t see how anyone else stands much chance whatsoever!!!

please explain how to make this simple process work beyond the point of “Sending the invite” which is as far as the documentation goes. and please sort this out its embarrassingly bad and unnecessarily complicated!!!

Thanks in advance

1 Like

Hi there, @maarten.westera! It sounds like you are doing everything correctly here. When inviting shared users, you can choose which devices and locations they have access to. As long as the shared user is logging in using the email address you’ve sent an invitation to, they should receive access to those devices.

While logged in on your Ring app, open the Menu, and select Settings. There you will see an option called “Users”, where you can manage shared devices and check on invitations. Here is our help center article for more tips and tricks when adding Shared Users. I hope this helps! :slight_smile:

I am having the same issue, user accepts invite, creates account and it was them to press orange button on the doorbell to be added. The doorbell is already in place and they should have to do that. Also it still shows invite pending but the already accepted it. Need help adding users after they accepted the invite and set up account.

Hi @Tnicole. It sounds like your Shared User is on the wrong Location. Once the Shared User is added, you should’t need to press the orange button on the Doorbell. Try having them switch Locations in the Ring app so they can view the device you’ve shared with them. You can find out more about Locations here. I hope this helps.

I have the same problem. I have tried to add my husband twice. I go through all the steps and he accepts the invite. The doorbell never shows up in his dashboard. I need this to work for both of us.

Hi neighbors. If the above mentioned steps didn’t correct the issue you are having with adding a Shared User, then you will need to reach out to our support team to look further into this for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Why should support team be required for such a fundamental process? There are obviously multiple users having the same problem (add me to the list). Why not look at modifying the process instead of using the standard “is your computer plugged-in” approach.

2 Likes

Same issue here. This is ridiculous. Once the invite is sent the invited user should just be able to open the app and see the devices. I’ve tried everything and it just doesn’t work.

2 Likes

I am having the same issue, I already have an account and so does my shared user, after many failed attempts (at least 7) on both mobile device and PC he was finally able to see my cameras. I have however not been so lucky. He has resent the invite multiple times and I have tried with my mobile and PC but it just says “no locations found” I have shared before and didn’t have any issues, something must be wrong on " Ring’s" end, Please help or fix this issue.

Same issue here. I have tried all the steps many times with three different users. I don’t understand how you can charge money for this app when this is not working.

Literally the same issue. Very frustrating!!! This sounds like a process gap that needs to be fixed ASAP.

All- try having the primary owner delete the shared user email completely and re-add them instead of resending the invite to an existing user. After 35 mins on with customer service, that worked.

2 Likes

Thanks for the suggestion, @Relle!

Deleting the shared user email and resending worked!!

1 Like