Ring Stick Up Cam - Plug In (3rd Gen) - Critically Low Battery Message

I’ve had a stick up cam plug-in (3rd Gen) since January. It has been great up until a few weeks ago when I noticed that within the app and device section, it shows as Battery Critically Low.

However this is a plug in cam, powered by a UK mains plug, so I am confused as to why it is advising a critically low battery.

I have un-plugged the cam and tried various troubleshooting with no luck.

I am wondering if anyone has had similar issues or if this is a known issue.

Is there a solution to fix the issue? I have held of contacting customer support via Phone but nothing seems to be working.

As I said it was fine for about 6 months and it has only suddenly started showing this message.

I have lost some functionality such as live view as it tells me the device power is too low.

Any help or advice would be greatly appreciated.

Thannks

2 Likes

I have had this happen to me a few times. When I unplugged the camera, it fixed the issue. Luckily my camera is in a place I can reach it easily.

1 Like

I had the same issue and I unplugged it like you suggested and the warning went away

1 Like

Same happened to me twice and realised if was down to heavy rain. Where you plug the power into the back if the camera isn’t properly waterproof. I just dried mine out, plugged it back in and put a bit of tape around the outside to stop water re-entering. Problem solved.

I’m having the same issue.

The best first step is to double check the power mode for your Stick Up Camera, in your Ring app. Many neighbors have also found success with checking on your Plug-In adapter connection at the Camera. Please ensure this is securely inserted, and also check the port to ensure there is no debris.

For further assistance, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like