Ring skill enabled but can't use in a routine

A few months ago, I installed a ring camera and flood light. I recently enabled the ring skill in the Alexa app and have used it a bit to disable and snooze motion alerts on the camera. I’ve tried unsuccessfully to create a routine to simplify the instruction but the ring skill doesn’t appear as an option when setting the action to a skill and selecting your skills. It indicates that no skills are enabled even though I’ve enabled 3 (Ring, Hulu and Spotify). I’ve followed the recommendations to disable the Ring skill, delete the devices (camera and light), then re-enable the skill and let it detect/add the devices back. I’ve tried this twice and have even tried logged off the Alexa app and uninstalled/reinstalled it with the same results. I’ve seen posts with many issues with the Alexa app and Ring devices which seems ridiculous since Ring devices are made by Amazon. Anything else I can try?

I have been able to get the snooze feature to work by using a custom action to say the words to set the alert snooze to 30 minutes but this doesn’t work for enabling motion alerts (even though Alexa says okay when I run the routine). So I know the Ring skill is at least partially working.

Hi @dubfamily3. You can create Routines in the Alexa app using different features on the Ring device, but you won’t see the Ring Skill as an option itself when setting a Routine. In the Routines menu in the Alexa app, you can select Smart Home under either part of the Routine, and you should see your compatible Ring devices listed there. Not every feature on your Ring device is available for use in a Routine.

If you don’t see a certain feature or capability for Routines involving your Ring devices, feel free to add it as a suggestion on our Feature Request board. We utilize the Feature Request board as a way to gather and share new ideas on features and devices with our teams here.

So the Ring skill (developed by Amazon) is available for Alexa’s routines (developed by Amazon). That makes no sense to me. And I tried selecting Smart Home but the Ring floodlight/camera is not supported.

Regarding routines, is there a reason I can’t set up a custom action followed by wait (5 minutes) followed by another custom action? Custom action is grayed out after added the first custom action. I’d like to disable motion alerts, wait 5 minutes then enable them. The snooze feature is useless as the lowest duration is 30 minutes and I don’t want it snoozed that long.

And I’m also having problems simply using the Ring skills on its own. I say “Alexa disable Ring motion alerts on front” (which is listed under the skill), Alexa says okay and motion alerts remain enabled. The same happens with the motion warning.

I have to say this is extremely frustrating and shouldn’t be this difficult to do simple instructions.

@dubfamily3 You can find some information on creating an Alexa Routine with your Ring devices here. More advanced Routine set ups may not work with Ring devices, as not every feature or capability is supported. For issues with the Ring Skill itself, try following the troubleshooting steps here. If issues with the Ring Skill in the Alexa app persist, but your devices are still working properly in the Ring app, I’d suggest visiting Alexa’s Help Center for further guidance.

I already found and tried the instructions for creating an Alexa routine with a Ring device via the first link you sent. When selecting which devices to snooze, the Ring camera is not listed (even though I’m able to set it up in a routine when the camera detects motion) . It will only work if I select all devices which I don’t want to do and clearly indicates that there’s a bug in which it’s not showing all available devices. As for the link you provided for the Ring skill, I tried that as well as I indicated in my first post. It would be nice if your instructions actually worked.

I will try Alexa’s help center, but I’m not optimistic that there is a solution and wish I’d discovered this when I got it as I would have returned it. I’ve already wasted so much time tried to get this to work.