Ring Pro - Unable to join the network

We have had the Ring Pro for about a year. Recently changed WiFi routers and re-named with the same name as before. Tried to reset and start over with Ring when not connecting. Keep getting the “unable to join the network” popup when looking for the Ring network. When looking at the WiFi on my phone there is no Ring network to connect to. Electrician verified 16-17 is being supplied to the ring. This has gone on for weeks and it has had plenty of time to charge up.

Everything worked previously as far as power and WiFi range so not understanding what changed. If the doorbell isn’t putting out the Ring WiFi network I am not even getting to the point where it attempts to connect to my local network.

I have reviewed this article and feel like I have done everything.

Same results when I try on my iPad vs. my iPhone.

Any suggestions?

Hi @Mike20169. I’m glad you were able to get the voltage verified on the wires going to your Pro. That’s always a good place to start when working with hardwired devices. There is a troubleshooting step you can try to get your Pro to go into setup mode, which is where the Pro speaks and says it is in setup mode, then emits the Ring wifi network for you to join to continue your setup. You can try doing a reboot by pressing and holding the setup button for 20–25 seconds and see if it goes into setup mode. If you have tried this step and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

@Justin_Ring

Thanks for the reply. We have tired to enter setup mode many time, on rare occasion does it say “setup mode.” We have also tried the hold for reset. Sometimes the light is circling blue or spinning white. Once or twice we were able to connect to the ring network and enter the password for the home network, but both times it failed to connect and we had to start over.